scieloSubmissionsReport broke plugin page

Hi all,

I installed the “SciELO Submissions Report” plugin in a journal of mine and it works well, I enjoyed it. But when this plugin is installed, my system plugin page doesn’t work. It shows just an infinite loading.

The plugin page and plugin gallery of each journal work as usual, but not the same for the plugin page of the site administration. I double checked it both on my OJS and in a blank OJS installation, and it’s a problem due to the Scielo plugin attivation. I restored the original situation removing the Scielo folder from the plugin folder.

Is it a known issue? I want use Scielo Submission Report plugin but I think it’s not very very safe because something goes wrong with it. How can I solve it?

I tried 2.0.4 and 2.0.2 plugin releases on both 3.3.0-6 and 3.3.0-4 OJS installatons.

Hi @Michevole,

We are from Lepidus and we developed this plugin for Scielo.

Could you please tell us what error appears in the PHP / Web Server log when you try to access your system plugins page?

CC @BonjourJhon

Hi @abadan and thanks for replying so quickly!
I paste here the log error.

2021/09/20 15:18:25 [error] 23479#23479: *50345 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to a member function getId() on null in /data/siti-www/ojs-omp/ojs3/ojs-3.3.0-4/plugins/reports/scieloSubmissionsReport/
Stack trace:
#0 /data/siti-www/ojs-omp/ojs3/ojs-3.3.0-4/plugins/reports/scieloSubmissionsReport/ ScieloSubmissionsReportForm->__construct()
#1 /data/siti-www/ojs-omp/ojs3/ojs-3.3.0-4/lib/pkp/classes/plugins/ ScieloSubmissionsReportPlugin->register()
#2 /data/siti-www/ojs-omp/ojs3/ojs-3.3.0-4/lib/pkp/classes/plugins/ PluginRegistry::register()
#3 /data/siti-www/ojs-omp/ojs3/ojs-3.3.0-4/lib/pkp/classes/plugins/ PluginRegistry::loadCategory()
#4 /data/siti-www/ojs-omp/ojs3/ojs-3.3.0-4/lib/pkp/classes/install/ PluginRegistry::loadAllPlugins()
#5 /data/siti-www/ojs-omp/ojs3/ojs-3.3.0-4/lib/pkp/classes/install/ Installer->__const" while reading response header from upstream, client:, server:, request: "POST /index.php/index/$$$call$$$/grid/admin/plugins/admin-plugin-grid/save-upload-plugin?function=upload&category=&plugin= HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.4-fpm.sock:", host: "", referrer: ""

(Please, be patient because PHP is not my first language :grinning_face_with_smiling_eyes:)

1 Like

I believe I have identified the bug, the plugin does not expected to be loaded on Administration → Site Settings > plugins

It works fine only if you access the plugin listing via a journal, in Settings > Website > plugins

If our team confirms this, we will soon release a corrective update.

Thanks for the info @Michevole!

1 Like

I’m glad my experience was useful. I hope to use soon your updated plugin again!
Thanks for your work.

Greetings, @Michevole

We released a fixing update, so it solves the problem you found. You can find it at v2.0.6.0

Thanks again for the report!

1 Like

I tried it in these last days and it works! Thank you very much for your development job

1 Like