Running a patch for 2.4.6

I’m new to running patches.
I have my patch file in the same dir as my ojs files. so using -p0 in patch command. Please see attached. The patch file I’m trying is

Some of the test-suite related files are included in the Git repository, but not distributed in the full standalone installation. These files (for example .travis.yml and anything under tests/) can be ignored in the patch process.

The next question, if you hit return after “File to patch:”, will be “Skip this patch? [y]”. Answering “yes” (the default) will proceed with the patch.

As a note, however, it looks like you are in the ojs install directory and using -p0. This should be -p1.

One final note: pulling the patch from Github like that will end with the warning patch: **** File lib/pkp is not a regular file -- can't patch. This indicates you will need to do the same process for the lib/pkp subdirectory from the pkp-lib shared library on Github.

Many thanks, with -p1 it also says can’t find file to patch. Please advise.

The -p option strips leading components from the path specified within the diff, e.g.:

diff --git a/.travis.yml b/.travis.yml

So, I’m pretty sure -p1 is correct.

As noted in my previous reply, I don’t think you should expect to find the .travis.yml, or anything under the tests/ directory, in your install. Are you finding otherwise?

Well, I tried again with -p1 and it worked. I just skipped the question about “Which file to patch”. Thanks a lot for the help. I have 2.4.6 and 3.0 running now.