Review form of a Journal not showing in OJS 3

#1

Good Morning all,

We QA our new upgrade OJS 3 instance and our user ran into this issue “I send it (submission) to myself to review, the review forms are not showing up for the reviewer. I selected the custom review form “2017-10 Review Form” but it is not appearing, nor is the default free text box review form. See screenshot below.”

I have tried playing around, looking at page source, apache error_log and OJS application log, but not seeing anything erroneous. I wonder if this has to do with configuration of application. Thanks for any help,

Best regards,

Dung.

#2

Hi Dung,

Have you checked that the review form is active (check the “Active checkbox” in Settings/Workflow/Review/Review Forms)?

Also, have you selected the review form in your Journal Section settings? If not, go to Settings/Journal/Sections and then click on the blue “edit arrow” for the journal sections that you wish to tie the review forms to.

Maybe your problem is more “technical” than this, but it is worth a try! =)

Best wishes,
Emma

#3

Hello @OpenAcademia,

First, thanks for your instruction, they are clear, I could follow the steps no problem at all. However, neither suggestions have resolved the issue.

I am on the fence for calling this a coding issue or issue for journal teams to work out such as form creation or configuration … etc.

I am a technical person my background is programming, I might have to debug this but that will be lengthy for such issue.

Thanks for your help anyhow.

best regards,

Dung.

#4

@asmecher Hello Alec,

I have spent some time debugging this issue, I got as far as knowing it is this file does not return expected forms (NULL instead). Nothing made it pass the iterate statment of this file reviewFormResponse.tpl

{iterate from=reviewFormElements item=reviewFormElement} … {/iterate}

“templates/reviewer/review/reviewFormResponse.tpl”

If you can point me where to look further, perhaps database?

Thanks!

best regards,

Dung.

#8

Hello @OpenAcademia,

Sorry for all the confusion, but we finally found out why and resolved it. Here is how:

“We think” after the upgrade from OJS2.x to OJS3.x, the forms stop loading as showed above. Solution is we had to create new forms within a Journal under (Settings/Workflow and Review Tab), after creating new forms they still do not load, that is because we did not create an Item within this form. This Item needs to be created and it is what we are looking for in the original question and screenshot. In another word, one must create item within form during the process of creating form for the Item to show in the review form (this form you select to during reviewer assignment process, the workflow is a bit convoluted). Here are attachments of creating new item within form.

creating new item of form:

details of item creation:

selecting form during reviewer assigment process:

1a/

1b/

Problem solved!

Thank you for your time.

Dung.

#10

Good to hear, Dung! Glad it worked out. =)

Best wishes,
Emma

#11

@OpenAcademia

One more issue to share. Our colleague ran into an issue where after review he hits submit button but a message

“Please fill in required fields”

would show and never go away (is this a bug?) even though he has certainly filled in all fields. see attachment below

and the url path looks like this

1.7.33.33/index.php/TLI/reviewer/submission/67865#formErrors

To resolve this issue:

The problem with this form is that the first field “ Before you start your review— " has the Reviewers required to complete item tick box incorrectly checked. As it’s just text and doesn’t have any actions for a user to take (tick a choice box or edit a textbox) - when you submit the form, the backend is still waiting for an answer to this question even though it’s impossible to enter one. Not sure why this validation is still an option in OJS 3 for a field that doesn’t include Response Options but it’s important to remember when creating new forms. See screenshot below.

I believe it is a bug because if users allowed to tick field required then input filed must be exist right? One can not require a field to be completed when field is text and not input.

Thanks to my colleague who found it.

Dung.

#12

Hi @dung,

This is a bit of a quirk in the form you created – a response is marked as required, but there’s no selection for the author to pick. I think the best resolution would be some kind of warning to the user that at least one response option is required for this kind of input.

Regards,
Alec Smecher
Public Knowledge Project Team

#13

Thanks @asmecher,
Agree, and I will pass solution on to others.
Dung.