[Resolved]Locale (en_US) not loaded during upgrade to 2.4.8

I am upgrading from 2.3.3 to 2.4.8 as part of my attempt to finally upgrade to 3.0. The installation/upgrade pages are not readable because the localed en_US is not loaded and texts are not displayed properly.

Has anyone else had the same issue and solutions?

Thank you.

Paul

Hi @Paul_Chen

Have you checked if your locale XML file is present in locale folder?

Regards,
Israel Cefrin
Public Knowledge Project Team

Hi @israel.cefrin,

Thanks for the response. Yes, it is. I am wondering if this has to do with PHP version. OJS 2.3.3 works with PHP 5.2 but not 5.4. Does 2.4.8 works with PHP 5.2?

Paul

Hi @israel.cefrin ,

I tried a few more things. I found out the problem was my old config.in.php file. I haven’t figured the specific issues yet. However I used the configuration file with the 2.4.8 with only the database connection information replaced. The display is fine. My new problem is this error:

A database error has occurred: Duplicate entry ‘257-2135-1’ for key ‘citations_assoc_seq’

How do I resolve this? Thank you.

Paul

I tried upgrading from shell. Here is the error message:

ERROR: Upgrade failed: ##installer.installFileError##

Paul

After a few hours trying and retrying, removing some duplicate entries for some keys, I was able to complete the upgrade process (from 2.3.3 to 2.4.8). The front end of the website seems working but again the backend is not. Looks like I am having the same problem before the upgrade. This time it shows a different error.

DB Error: The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET MAX_JOIN_SIZE=# if the SELECT is okay

I read some threads saying this should have been taken care in 2.4.8.

Oh, I just noticed on the home page there is a notice saying I am still having 2.3.3 not 2.4.8. I tried upgrading to 3.0 but it said unsupported. I noticed there are 120 database tables in the database as opposed to 100 tables in 2.3.3. Does it mean my upgrade was not complete?

Paul

Hi @Paul_Chen,

The last step the upgrade performs is to update the version number – so if your OJS is still reporting version 2.3.3, the upgrade didn’t complete. The command-line installer should provide helpful output to show where it stopped.

Regards,
Alec Smecher
Public Knowledge Project Team

@asmecher,

I used the web upgrade method. Since the program is running Ok. Can I just manually change the version number so that I can move on to upgrading to 3.0?

Thanks.

Paul

I did turn on debug during the upgrade so that I was able to see what went wrong and manually intervened. It was in fact didn’t show a message saying the upgrade was complete.

Hi @Paul_Chen,

I’d suggest turning off the debug setting (it’s very verbose) and using the command-line tool to run the upgrade (it provides more helpful output). I don’t recommend manually editing the version number in the database, as that’s probably not the only step that didn’t complete.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher,

I finally successfully upgraded to 2.4.8. I still haven’t solved my database issue associated with “MAX_JOIN_SIZE” error. I am upgrading it to 3.1.0.1. After trying a few times and fixing database problems, I have come to this far with this last line “Unknown locale component”. It didn’t say whether it is an error or upgrade failed. It just stopped there.

[code: Installer Installer::installDefaultGenres]

[code: Installer Installer::migrateArticleMetadata]
[data: dbscripts/xml/upgrade/3.0.0_update.xml]

[code: Installer Installer::clearDataCache]

[code: Installer Installer::migrateUserRoles]

[code: Installer Installer::fixReviewForms]

[code: Installer Installer::htmlifyEmailTemplates]
[note: docs/release-notes/README-BEACON]

[code: Installer Installer::installEmailTemplate]

[code: Installer Installer::installEmailTemplate]

[code: Installer Installer::installEmailTemplate]

[code: Installer Installer::installEmailTemplate]

[code: Installer Installer::installEmailTemplate]

[code: Installer Installer::installEmailTemplate]
[data: dbscripts/xml/upgrade/3.0.0_scheduledTasks.xml]

[code: Installer Installer::localizeCustomBlockSettings]

[code: Installer Installer::convertEditorDecisionNotes]

[code: Installer Installer::convertQueries]

[code: Installer Installer::migrateFiles]

[code: Installer Installer::convertSupplementaryFiles]
Unknown locale component

Thanks.

Paul

Hi @Paul_Chen,

Try turning on the show_stacktrace option in config.inc.php; it should result in more information being dumped when an error is encountered.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher,

I will try again (I have to start from a clean database every time). By the way, is the “MAX_JOIN_SIZE” issue resolvable through upgrading to V3 or modifying the scripts? I am using Bluehost Shared Pro hosting service. They would not increase the max join size.

Thank you.

Paul

Hi @Paul_Chen,

I’m about to release OJS 3.1.1, which I believe should reduce the join requirements for some areas that have hit problems before.

Regards,
Alec Smecher
Public Knowledge Project Team

Do you have a firm release date?

@asmecher,

I ran upgrade again and failed. Here is the detailed info:

[code]

<h1>Unknown locale component </h1><h4>Stack Trace:</h4>
<strong>File:</strong> /home2/abepubli/public_html/ojs3101/lib/pkp/classes/submission/SubmissionFile.inc.php line 629<br />
<strong>Function:</strong> PKPLocale::requireComponents(1, Null)<br />
<br/>
<strong>File:</strong> /home2/abepubli/public_html/ojs3101/lib/pkp/classes/submission/SubmissionFileDAODelegate.inc.php line 95<br />
<strong>Function:</strong> SubmissionFile->_generateName()<br />
<br/>
<strong>File:</strong> /home2/abepubli/public_html/ojs3101/lib/pkp/classes/submission/SupplementaryFileDAODelegate.inc.php line 36<br />
<strong>Function:</strong> SubmissionFileDAODelegate->insertObject(Object(SupplementaryFile), "files3/journals/2//articles/1/submission/proof/1-14-2-1-10-20080...", False)<br />
<br/>
<strong>File:</strong> /home2/abepubli/public_html/ojs3101/lib/pkp/classes/submission/PKPSubmissionFileDAO.inc.php line 383<br />
<strong>Function:</strong> SupplementaryFileDAODelegate->insertObject(Object(SupplementaryFile), "files3/journals/2//articles/1/submission/proof/1-14-2-1-10-20080...")<br />
<br/>
<strong>File:</strong> /home2/abepubli/public_html/ojs3101/classes/install/Upgrade.inc.php line 1403<br />
<strong>Function:</strong> PKPSubmissionFileDAO->updateObject(Object(SubmissionFile))<br />
<br/>
<strong>File:</strong> (unknown) line (unknown)<br />
<strong>Function:</strong> Upgrade->convertSupplementaryFiles(Object(Upgrade), Array(1))<br />
<br/>
<strong>File:</strong> /home2/abepubli/public_html/ojs3101/lib/pkp/classes/install/Installer.inc.php line 415<br />
<strong>Function:</strong> call_user_func(Array(2), Object(Upgrade), Array(1))<br />
<br/>
<strong>File:</strong> /home2/abepubli/public_html/ojs3101/lib/pkp/classes/install/Installer.inc.php line 265<br />
<strong>Function:</strong> Installer->executeAction(Array(3))<br />
<br/>
<strong>File:</strong> /home2/abepubli/public_html/ojs3101/lib/pkp/classes/install/Installer.inc.php line 186<br />
<strong>Function:</strong> Installer->executeInstaller()<br />
<br/>
<strong>File:</strong> /home2/abepubli/public_html/ojs3101/lib/pkp/classes/cliTool/UpgradeTool.inc.php line 88<br />
<strong>Function:</strong> Installer->execute()<br />
<br/>
<strong>File:</strong> /home2/abepubli/public_html/ojs3101/lib/pkp/classes/cliTool/UpgradeTool.inc.php line 64<br />
<strong>Function:</strong> UpgradeTool->upgrade()<br />
<br/>
<strong>File:</strong> /home2/abepubli/public_html/ojs3101/tools/upgrade.php line 34<br />
<strong>Function:</strong> UpgradeTool->execute()<br />
<br/>

Hi @Paul_Chen,

Do you see the following line in lib/pkp/classes/i18n/PKPLocale.inc.php?

define('LOCALE_COMPONENT_PKP_COMMON',           0x00000001);

Regards,
Alec Smecher
Public Knowledge Project Team

@asmecher,

No, I don’t. Should I or where should I insert this line?

Paul

Hi @Paul_Chen,

Hmm, that should definitely be included in OJS 3.1.0-1 – is it possible that you’ve somehow mixed the code from different versions of OJS together?

Regards,
Alec Smecher
Public Knowledge Project Team

Hi @asmecher,

It can’t be. Where I should I insert it?

Paul