Required folder missing, quickSubmit Plugin unsuitable for OJS 3.1.2-4? [solved]

We recently upgraded our OJS to the latest release 3.1.2-4. There were no serious issues. We now tried to install the QuickSubmit plugin by putting the files from Github directly into the respective folder. OJS recognized them and shows the plugin in the list of installed plugins. However, when I go to a journal click on import/export data, I get a blank page and the error message

require_once(/var/www/ failed to open stream: No such file or directory

I checked and indeed, there is no such directory in our OJS installation. Is this missing due to an error during upgrade or is the quickSubmit plugin requiring obsolete files and is not suitable for the new OJS version?
I cannot install the plugin via the plugin gallery because the gallery is not working yet (its empty). The plugin was installed and working with our previous OJS 3.1.0-1.

Hi @heike_riegler,

You probably got the master branch from GitHub, which won’t be compatible with your OJS. It’s best to use the Plugin Gallery to install plugins, as it’ll take care of compatibility checks and get the right versions for you. If that’s not possible, you can get the right version from the Releases area of the GitHub repository.

Alec Smecher
Public Knowledge Project Team

I now took the latest release of the plugin and it works.Thanks for spotting this mistake so quickly.


1 Like