References metadata disappear in submission

we have encountered problems inserting metadata into the references section in submissions.
When we receive submissions with no references metadata under the publication section, we cannot update them later because all the text disappears every time we click save.
What could make this happen? We have version
I have tried searching for a similar topic, but no luck.

Thank you for the support.

Hello @transitionacademia,

Hmmm… that’s strange. Are you able to check your PHP error logs and see if you see any relevant errors there?

PKP Team

Hello @rcgillis,
It seems that the problem is caused by the special signs (for example, ü, İ, cł, ł) present in the authors’ foreign names or titles. If there is even one special character, it doesn’t save any.
Do you encounter the same problems?

Thank you very much

Hi @transitionacademia,

No - I didn’t encounter the same issue. I tested this and it worked fine for me. There is a similar post here: Cant add non English metadata after upgrade[OJS] - #4 by asmecher -

You may also wish to try upgrading to 3.3 - but that’s not guaranteed to resolve the issue - it may be an issue with the character encoding settings in your database - as per the post I link to (but I can’t say for certain).


Thanks, @rcgillis,
we have solved the problem with your link.
It was indeed a problem just for some tables that didn’t recognize special characters.


1 Like

This topic was automatically closed after 3 days. New replies are no longer allowed.