Reassigning reviewer in OJS


We are currently running OJS and have a journal where the editor has assigned a reviewer but has somehow accidentally declined on their behalf. they would like to reassign the reviewer but their reviewers status is “stuck” on assigned.

When I look at the event log, I can see multiple events logged as: Review assignment accepted by proxy but have not found any documentation on what this is or how it is accomplished.

I saw an older post from May 2016 where this same question was posed but did not see a solution.

Thanks in advance from Acadia University.

It sounds like this is still an open issue in 2.4.x:

Hi @scottyo,
Clinton has posted the link to the May 2016 thread where I described the bug. If you have access to the OJS source code, the thread also contains the simple code fix, which is to add the declined field to the SELECT statement.

If you don’t have access to the code, I have a workaround that will let you reassign reviewers with just a bit of extra work than normal. The underlying problem with the 2.4.x code is that a mistake in the SQL query prevents the “Reassign” link from being displayed on the page. However, you can construct that link manually in your browser URL entry field as follows:

Note the Submission ID of the submission and then note the User Id # by hovering your mouse over the link to the user profile of the reviewer in question and noting the number in the URL. If you’re doing it from the Select Reviewer page (which is likely since you’re trying to reassign them, it’s the second of the two numbers present in the URL).

Then in the browser entry field replace the caps words below with the appropriate values and hit Enter. The reviewer will be reassigned and the browser will return to the submission Peer Review page.


You might have to change the “editor” with “sectionEditor” if you only have SE access.


Thank you @rkemp!

This worked by logging in as the journal editor and going to the select reviewer page. I was able to reassign a previous reviewer who had mistakenly declined.

A note about the entry to the browser: I did not succeed first but then I understood that our domain starts with ojs. After deleting ojs/ from the entry it worked well. Thus, you may need to check how your domain is named if the entry does not seem to work.

Hallo, has there been any official fix to this problem?
Thank you

Hi all,

See: Permit declined reviews to be reinitiated · Issue #4789 · pkp/pkp-lib · GitHub

This has been implemented and will be released in OJS/OMP 3.4.0. (See the PKP Roadmap for estimated release dates.)

Alec Smecher
Public Knowledge Project Team

This topic was automatically closed after 3 days. New replies are no longer allowed.