QuickSubmit requires PHP 5.6

Super excited to see the QuickSubmit plugin ready to go - thanks so much for building this critical plugin for 3!

However, we are running our 3.0.2 sites on PHP 5.4 which meets the requirements for OJS 3, but it looks like the QuickSubmit plugin requires a minimum PHP 5.6 environment? Is there any way around this without an upgrade to our PHP (which will also require an OS upgrade for us)?


Hi @sfbetz,

We’ve reviewed that plugin’s code and it looks like it actually doesn’t have any requirements beyond what OJS 3.x needs, so you should be OK with PHP >= 5.3.7.

Alec Smecher
Public Knowledge Project Team

Excellent news! That saves us some infrastructure work. Thanks so much @asmecher.