Problems with OJS 3 Upgrading, no reverting?

Hi. Our journal is at . We’ve been using OJS … When we last upgraded (back in April), we also migrated to a different server, and mostly, things seemed to be working, although the article image thumbnails in the ToC’s were not appearing (perhaps a broken path?)

Yesterday, I installed 3.0 in a new directory, and then I copied the database (with a new name & user) and copied the public files and pointed the domain to that directory, adjusted the to reflect the new db and ran the upgrade. It did continue to cycle with the circle, but eventually it seems to have been successful. (At first there was an error simply saying “{“status”:true,“content”:”\n\n\t\t\tHelp\n\t</a>\n\n\n\n" on most pages, however I saw the suggestion here to clear the browser cache and that did the trick.)

However, besides losing my double sidebar layout, the main problem was that the HTML galleys no longer appeared in the middle of the OJS framework, but just as a plain file that has to be downloaded and opened. (And appears without any CSS.) Not sure whether that is the new standard, or whether it appears differently with XML, but the editor didn’t like it, so I tried to go back…

I pointed the domain back to the old directory, and therefore I assume, the old database, and I changed the permissions on the 3.0 directory so that it was inaccessible.

However, now none of our galleys are loading! When you click on an article, the HTML version appears to load the frame (and “no refbacks”) but there is no content. Similar blanks when you try for a PDF.

I saw that you had said it’s not possible to revert, but I am still working from the original (not upgraded) database (and codebase.)

Separately, we’ve also been having trouble uploading certain images (in both the journal set-up step 5, which was throwing a 403 forbidden error AND in our OMP installation, where our logo cannot be uploaded, as it says ‘invalid file format’) … The first error was finally corrected by asking our server admin to whitelist some mod_security rules in apache to allow us to upload, but neither specific whitelisting NOR temporarily entirely disabling mod_sec would fix the OMP issue blocking uploads.

Anyway, since the site is now effectively entirely broken (no articles appearing, only the full issue PDFs can be downloaded), and our editor is pressing me to release our next issue any day now, I am in a difficult situation and not sure how to troubleshoot this.

ANY suggestions would be most appreciated.

Dear OJS Team,

Thanks for all your attemps for development of OJS.
There is a serious problem in upgrading from OJS 2.X to 3.

There is an error at middle of upgrading: "
A database error has occurred: Table ‘issue_galleys_stats_migration’ already exists"

Even when the issue_galleys_stats_migration is deleted. again there will be an error of 'A database error has occurred: Duplicate entry ‘defaultthemeplugin-0-enabled’ for key ‘plugin_settings_pkey’

There are may users that want to upgrade from 2.x to 3, but they are not able to do that. If you search in forums of OJS, you can see nobody still was able to solve this problem.

On the other hand OJS 2.x has some security bugs and hackers easily hack the OJS 2.x while we cannot do anything to protect our websites.

We appreciate if you guide us how to solve the problem that we face for upgrading from OJS 2.x to 3.

Thanks very much for your time for reading our email.

I’ve made new backups, patched the code so that we’re now running but it seems that still no articles are appearing.

At least having the articles (without CSS nor OJS frames as they seemed to be with OJS 3) would be better than having no article galleys appearing at all, so I will point the subdomain back over to the new directory soon if I can’t figure out how to fix the old site.

Perhaps we should try XML galleys instead with the new eLens viewer? In the PKP OJS 3.0 demo journals, the XML articles appear very nicely (scrolling on right with a static left sidebar of links to metadata and article outline.). Also very much looking forward to the Open Typesetting Stack described here.

Thanks for any advice on what I’m missing here.

Hi @gidget,

Were you also operating on a copy of the files directory? The upgrade process rearranges this, which might explain the 2.x install having trouble accessing files if they used the same storage area. I’ve already coded some improvements to e.g. the HTML presentation, so may be able to help you get set up with that if you want to try pushing ahead.

@OJSUSER11, please don’t threadjack or double-post. I’ve responded to your other post at UPGRADING OJS 3.0.0 A database error has occurred: Duplicate entry 'tinymceplugin-0-enabled' for key 'plugin_settings_pkey' - #14 by OJSUSER11.

Alec Smecher
Public Knowledge Project Team

Ah, thank you, that is good news. So the HTML galleys should be pulled into the new framework? It seemed when one clicked on a galley that it only offered to download (and display in browser.) Although I could see pdf & xml formats in the demo version, I couldn’t find any HTML. If that’s the case, then I think we will push forward with the 3.0 although I may have to fix some or most of our old HTML galleys.

I’ve actually never been very clear on the proper format for the html, because I’ve uploaded the html files with their own head tags, but then usually understood that the system was superimposing another set of head tags (with the proper metadata). See this article describing this doubling as confusing. Sometimes, perhaps in trying to avoid that duplication, I’ve had a similar issue to this user where they weren’t recognized as html and appeared orphaned on a white background without framing.

My second fear about moving is around getting the same uploading files error as we are getting with our OMP installation.. Here is a screenshot:

As I said above, disabling mod_security entirely didn’t even fix this problem. (It’s back on now, but needed to “whitelist”* some rules as per the error logs, so that OJS 2.4.8 step 5 “the look” would again allow uploads.)

Should OJS and OMP share the same files directory? I had configured it that way, and it is outside the public_html directory. (That may be why thumbnail images paths were broken when we moved servers… both for the OJS article covers and the OMP book covers.)

These errors began occurring after upgrading to OMP 1.2.0 in April. You can see how there is obviously a path problem for the system icons as well:

This block led me to put the whole OMP site on hold for our press over this summer, and we’ve continued to publish with drupal, which has it’s own set of upgrading headaches, and has not nearly such nice standardized presentation of our book metadata, so I would very much like to figure out how to fix this issue and move back to promoting our OMP site instead. I’ve become quite enthusiastic about the Dublin Core Initiative however, and I miss that google scholar would quickly disseminate publications upon release (as they do our OJS issues).

Finally, I’d just like to say thank you Alec, for all your work on these codebases (and hand-holding in the forums) over the years. As an activist coming to this without the academic background, I’ve really learned so much about the proper publication workflow through both OJS and OMP, and I appreciate your patient explanations (and Sunday AM contributions!) I have tried to pay it forward by teaching others, and will continue to do so.

best regards,
pj lilley
Production Editor, Radical Criminology & Thought|Crimes Press

  • Just wanted to note that the term “white-listing” is not mine, but I’m using it because I needed to ask upstream tech support to do this for me. Similarly, ‘black-listing’ domains… it’s awkward & I’d like to see us try harder to find new words, as I feel they’re yet another example of racism embedded in our tech lingo.

Ok, tried to go with the 3.0 once more, but ran into these main issues:

  • same “no file uploaded or invalid file type!” error when trying to upload jpg or png to the website settings (title image and so forth… In the article production section I could upload files without difficulty)

  • neither HTML nor PDF galleys seemed to be loading

  • a couple of sidebar blocks and the footer were missing (would need to recreate)

Given this situation, I pointed the domain back to the installation and uploaded a zip file of just the journal files subdirectory to the appropriate dir. (I noted that OMP files are in a separate sub-directory.) Happily, at least the articles are back now. However, that compression process unfortunately did not preserve the original date/timestamps on these files. How bad is that? Will it be a serious issue?

I will try to work out the uploading issues on our OMP first (and publish this next issue!) and then when I can sort these issues out first, will try again with the 3.0 upgrade process.


I don’t think the filesystem level date and timestamps are exposed anywhere in the product, so the modified timestamps should not be a problem from the application’s perspective.

Hi @gidget,

Only certain parts of the system care whether what you’re uploading is detected as an image or not, so that explains why some areas complain about PNGs not being detected correctly and others will accept the file without complaint. See this FAQ entry for information on how OJS detects file types, and what you may need to configure to resolve the problem with types being incorrectly detected.

As for HTML publishing, if/when you’re ready to tackle that, the git issue is Resolve HTML publishing issues · Issue #1825 · pkp/pkp-lib · GitHub – there are a couple of pull requests there that it should be possible to cherry-pick over to a 3.0.0 installation without too much trouble. I expect we’ll get those merged fairly soon, so if you’re itching to get that aspect resolved, let me know and I’ll check whether it’s ready to go.

Alec Smecher
Public Knowledge Project Team

1 Like

upgrade from 2.4 to 3.0 please help me with this

Hi @Veliyana_L.A,

Could you post this as a new topic rather than re-opening an old thread? Include your exact OJS version numbers.

Alec Smecher
Public Knowledge Project Team

SOLVED. thanks for all help


How did you solve this problem? Could you help me in this topic, please?

default language is english