Problems upgrading the QuickSubmit plugin

We have a number of journals that wish to use the QuickSubmit plugin. The only problem is that plugin activation checkbox appears to be grayed out on the Installed Plugins page. On the Plugin Gallery page, it says the this plugin “Can be upgraded”. Nice! So I try to upgrade and it tells me that the latest version is v1.0.2.0 and was released on 2018-04-04. Strangely, when I hit the upgrade button, it indicates that it has upgraded QuickSubmit to v1.0.1.0 (not the expected v1.0.2.0). And, alas, the QuickSubmit entry on the Installed Plugins page is still grayed out.

Has anyone seen this problem before? I tried upgrading on both v3.1.1.2 and the latest v3.1.1.4 without any luck.



Are you trying to upgrade the plugin with the Administrator role?

Regards, Primož

Hi @primozs,

Yes. I’m getting the distinct vibe that the top level admin does not not in fact have authorization to make these types of changes.



Assuming that top level admin is not able to upgrade a journal plugin, I tried to upgrade the QuickSubmit plugin by using the “Login As” functionality and logging in as the Journal Manager for one of our test journals. Unfortunately when I went to the Plugin Gallery I could not find any way to upgrade the plugin. The popup indicated “Plugin already installed, but can be updated to a newer version.” but there was no obvious way of doing it.

Am I missing something obvious. Is upgrade not available as “Login As” user? Confused.


I’m afraid we have the same problem after upgrading from to We could not upgrade it in the Gallery. Upgrading using tools/upgrade.php upgrade seemed to work, but there is still “Can be upgraded” message active in the Gallery. And this is what we have in the info window:


So we are not sure, whether we have the latest version. Please, help.

P.S. We also could not upgrade the Manuscript theme through the Gallery after upgrading to