Problems accesing to open content


When I try to access to my ojs site without login, I can’t see any content.
Originally (four months ago or more) I had configured the “Access Distribution Setting” to “The journal will require subscriptions to access some or all of its contents” (I guess).
This afternoon I had all the content ready to display to all users, and I changed the option to “The journal will provide open access to its contents”.
This change didn’t do anything on my ojs journal. I have already to login if I want to see the content.
I also checked “Site Access Options” in “Users & Roles” section, but all values were correct.

I upgraded to new OJS 3.1.2-4 (from 3.1.2-1) to try to solve the problem, but this not worked for me.
I checked some values directly in the data base, but I think it was all perfect (restrictSiteAccess=0, disableUserReg=1, restrictArticleAccess=0, publishingMode=0).
All the articles of the journal have been uploaded with quickSubmit plugin.

All the installation is uploaded in an external hosting, so I don’t have access to PHP log… I think.
I don’t know wich is the next step, could someone help me?

Thank you very very much in advance.

Hi @efbarriguete,

Thanks for your question! Would you be able to provide screenshots of your journal or provide additional information on what information is and isn’t being displayed?

Kind Regards,
Patricia M.
Public Knowledge Project

Hello @pmangahis,

First of all thanks for your response. I have finally solved the problem few days ago by installing OJS from scratch again. Anyway in that process I realised that OJS have an option that I had forgot (and now I’m sure that I unchecked it in my first installation). Here I upload some captures with the location of my problem (it’s very stupid, but sometimes these things happens):




You have to access to “Administration” zone and click over “Hosted Journals” option.
Then “Edit” the journal that you want to change its public visibility, and UNCHECK “Enable this journal to appear publicly on the site”.

I hope this helps someone as distracted as me.
Thank you once again @pmangahis!!!

I can’t edit last post, so I explain here an error:

Where I wrote UNCHECK, I really would have to say CHECK