Problem with DOI registration

Hi,

So, I was trying to deposit and activate our last edition’s DOIs. For one of the articles I am receiving this error:

<?xml version="1.0" encoding="UTF-8"?>

<doi_batch_diagnostic status=“completed” sp=“ds4.crossref.org”>
<submission_id>1468495325</submission_id>
<batch_id>_1588267185</batch_id>
<record_diagnostic status=“Failure”>

Error: cvc-pattern-valid: Value ‘http://orcid.org/’ is not facet-valid with respect to pattern ‘https?://orcid.org/[0-9]{4}-[0-9]{4}-[0-9]{4}-[0-9]{3}[X0-9]{1}’ for type ‘orcid_t’.
Error: cvc-complex-type.2.2: Element ‘ORCID’ must have no element [children], and the value must be valid.

</record_diagnostic>
<batch_data>
<record_count>1</record_count>
<success_count>0</success_count>
<warning_count>0</warning_count>
<failure_count>1</failure_count>
</batch_data>
</doi_batch_diagnostic>

I do not understand the error. What am I supposed to do? I have tried everything.

Thank you very much.

Best regards,
Cris

Hi @Cristiana_DOBRE,

It looks like one of your authors somehow has an invalid ORCID of http://orcid.org/ instead of a proper ORCID iD (e.g. ORCID). Review your authors and make sure that the ORCIDs are valid. (I’m not sure how this would’ve gotten entered – there are checks to ensure that the IDs are valid in the user interface. Maybe via import/export?)

Regards,
Alec Smecher
Public Knowledge Project Team

Dear @asmecher
i have the same problem with registering DOI number because the same error i found, i tried to change ORCID of authors by the many ways, but without success. Is there some way to change ORCID of authors as editor or administrator? Because i failed.

If you can get the xml which was sent to Crossref, you can check the format, which should look like this:
<ORCID>https://orcid.org/0000-0001-9160-0420</ORCID>
This error comes when the ID number is more or less than 4x4, in groups.