Problem when editing a review OJS 3.X


#1

Hi.

I have the version OJS 3.1.1.0 and I want to modify a review created in the previous version OJS 2. But when I go to the section of production, since I want to modify a pdf that was loaded as galley, I get the following notification after clicking the tab Production: “Phase not started.”

How can I solve this problem?


#2

Hello, someone can help me or what manual I can follow. Very grateful as always.


#3

Hi @gardbeat,

Can you please post a screenshot of the submission you’re trying to modify?

Thanks,
Amanda Stevens
Public Knowledge Project Team


#4

Hi @astevens . The article was already sent and published two years ago. The problem has come to migrate this year the website of ojs 2 to ojs3, where when clicking the article happens the following, I send you the link: https://revistabarataria.es/web/index.php/rb/issue/view/6

It only happens with the reviews (Book Reviews), which is at the bottom.

It does not show the pdf (uploaded as galley) or enter the metadata, after clicking on the title.


#5

Hi @gardbeat,

You may need to send the submission to production and schedule it for publication again on the back end in order for the metadata and the galley file to appear on the front end. It sounds like some data was lost during the upgrade. Please try this and let me know how it goes.

Thanks,
Amanda Stevens
Public Knowledge Project Team


#6

Hello @astevens,

When I access the control panel and I send it to production, I see the following: “Currently, he does not have access to this phase of the work process.”

Indicate that if I am logged in as administrator (same user that I create the Bibliographic Reviews), if I can visualize it, if I can see it on the web.

How could I solve it?


#7

Hi @gardbeat,

Since this is only happening with the Book Reviews, I wonder if something happened to the section during the migration. Can you go to Journal Settings > Sections and make sure the section still exists and is configured properly?

Thanks,
Amanda Stevens
Public Knowledge Project Team


#8

Hi @astevens,

If it exists and is created within the sections within the magazine.

What can it be then?


#9

Hi @gardbeat,

I just opened the link you sent earlier and now I see the pdf link for the reseña bibliográfica. Were you able to solve the problem?

Thanks,
Amanda Stevens
Public Knowledge Project Team


#11

Hi @astevens,

I have been able to add the pdf through the library.

But I have tried in another number, this link of bibliographic reviews: https://revistabarataria.es/web/index.php/rb/issue/view/13

Then I tried to create one of 0, upload the file, but it tells me that I do not have permission to edit or send to production. My user has all the roles.

Thank you and I am waiting.


#12

Hi @gardbeat,

Can you check the data in your submissions table for the book reviews compared to the other published submissions that are working and look for an inconsistency or visible difference?

Best,
Amanda Stevens
Public Knowledge Project Team


#13

Hi @astevens , I have checked my username and connected with another user who has all the privileges and the same thing happens. What can I try?


#14

Hi @astevens,

What can I try to solve this incident that has occurred from step 2 to step 3?


#15

Hi @gardbeat

In my last post I suggested that you check the data in your submissions table to look for inconsistencies or differences.

Best,
Amanda Stevens
Public Knowledge Project Team


#16

It is always good to assign Section editors to Sections. That helped me to solve some problems with submissions in workflow.
Also, perform your editor work as editor, not admin. They should be always considered as different accounts although they have many permissions that are common.


#17

Hi @astevens,

I’ve been looking at my shipping table and I do not see anything wrong. Indicate that these reviews, were created and worked under the previous verion (ojs 2) but that after migrating, have stopped working. My question, in the face of impossibility. Is there a method of re-creating them without having to start the process from 0?

Thank you and I look forward to your response.


#18

Hello @vvucic, the problem does not come from the reviewers, since in its day it was validated and it worked under version ojs 2. But after making the migration (towards ojs 3), all the articles that were inherited from the ojs 2 but the reviews created under ojs 2.


#19

Yes, I know. I have had similar case with some journals. So, please pay attention to what I asked you.


#20

Indeed @vvucic, I have logged in with an editor profile and if he has left me. Thank you very much and I’m sorry I did not understand you.