Plugins installation problems in OJS 3.1.2.1

Hi,
I have a problem with installing plugins in OJS 3.1.2.1. Every time I want to install a plugin (I have tried QuickSubmit plugin and Translator plugin) there is a warning “Are you sure you wish to install this plugin?” and after pressing OK nothing happens.

I was looking in other posts in this forum a solution so I have downloaded files with Quicksubmit plugin from GitHub (https://github.com/pkp/quickSubmit) and put it in the import/export direcotry.
After that I can see the Quicksubmit plugin in Installed plugins and in Tools–>Import/export but after trying to run it the HTTP Error 500 appears.

What can I do?

I have to put on the server over 400 articles till the end of the year. The Quicksubmit plugin would be perfect for this. I have also problems with translation Polish signs so I need the Translator plugin.

Please help…

In the DevTool there is an error:

jquery.min.js:2 [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check https://xhr.spec.whatwg.org/.
send @ jquery.min.js:2
ajax @ jquery.min.js:2
a.pkp.controllers.NotificationHandler.fetchNotificationHandler_ @ pkp.min.js:212
a.pkp.classes.Handler.handleEvent @ pkp.min.js:111
dispatch @ jquery.min.js:2
y.handle @ jquery.min.js:2
trigger @ jquery.min.js:2
triggerHandler @ jquery.min.js:2
a.pkp.controllers.NotificationHandler @ pkp.min.js:211
a.pkp.classes.ObjectProxy.parent @ pkp.min.js:106
a @ pkp.min.js:104
a.pkp.classes.Helper.objectFactory @ pkp.min.js:103
(anonymous) @ pkp.min.js:430
each @ jquery.min.js:2
each @ jquery.min.js:2
a.fn.pkpHandler @ pkp.min.js:430
(anonymous) @ VM2830:4
l @ jquery.min.js:2
c @ jquery.min.js:2
setTimeout (async)
(anonymous) @ jquery.min.js:2
u @ jquery.min.js:2
add @ jquery.min.js:2
(anonymous) @ jquery.min.js:2
Deferred @ jquery.min.js:2
then @ jquery.min.js:2
w.fn.ready @ jquery.min.js:2
w.fn.init @ jquery.min.js:2
w @ jquery.min.js:2
(anonymous) @ VM2830:2
m @ jquery.min.js:2
Re @ jquery.min.js:2
append @ jquery.min.js:2
(anonymous) @ jquery.min.js:2
z @ jquery.min.js:2
html @ jquery.min.js:2
(anonymous) @ jquery-ui.min.js:13
setTimeout (async)
(anonymous) @ jquery-ui.min.js:13
u @ jquery.min.js:2
fireWith @ jquery.min.js:2
k @ jquery.min.js:2
(anonymous) @ jquery.min.js:2
load (async)
send @ jquery.min.js:2
ajax @ jquery.min.js:2
load @ jquery-ui.min.js:13
(anonymous) @ jquery-ui.min.js:6
_create @ jquery-ui.min.js:13
(anonymous) @ jquery-ui.min.js:6
_createWidget @ jquery-ui.min.js:6
t.. @ jquery-ui.min.js:6
(anonymous) @ jquery-ui.min.js:6
each @ jquery.min.js:2
each @ jquery.min.js:2
t.fn. @ jquery-ui.min.js:6
a.pkp.controllers.TabHandler @ pkp.min.js:196
a.pkp.classes.ObjectProxy.parent @ pkp.min.js:106
a @ pkp.min.js:104
a.pkp.classes.Helper.objectFactory @ pkp.min.js:103
(anonymous) @ pkp.min.js:430
each @ jquery.min.js:2
each @ jquery.min.js:2
a.fn.pkpHandler @ pkp.min.js:430
(anonymous) @ website:141
l @ jquery.min.js:2
c @ jquery.min.js:2
setTimeout (async)
(anonymous) @ jquery.min.js:2
u @ jquery.min.js:2
fireWith @ jquery.min.js:2
fire @ jquery.min.js:2
u @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
_ @ jquery.min.js:2
jquery.min.js:2 POST http://rocznikbezpieczenstwa.pl/ojs/index.php/rbm/$$$call$$$/grid/plugins/plugin-gallery-grid/install-plugin?product=translator 500 (Internal Server Error)

Can somebody help me please?

Hi @doridek,

Check your PHP error log for details.

Regards,
Alec Smecher
Public Knowledge Project Team

Hi!

W have wrote to my hosting service and they checked it. It apperas that my version of PHP was to high.
After I have chnged it all works fine.

Best regards
Dorota