Plugin Problems with OJS

I’m having multiple problems with my OJS system. The latest is with plugins. I’m trying to install the defaultManuscript theme. I unpacked the theme and copied to ojs/plugins/themes as directed in the readme. I made sure all permissions with 755. I can see the theme in the plugin gallery, but when I try to install, I get nothing. If I log back in, I get an error notification. It reads as follows: “The uploaded plugin archive does not contain a folder that corresponds to the plugin name.”

Also, I cannot get the list of plugins to load though that may be because there are none to load. I have tried to install other plugins. They generate the same behavior and same error message. Can anyone help me solve this problem?

I’m been having issues upgrading my OJS installation as well. I don’t know if the two problems are related.

Hi @ACastelletto,

Can you recheck theme’s directory name, it should be defaultManuscript as per installation instructions: GitHub - NateWr/defaultManuscript: A clean, simple OJS 3 theme with a boxed layout that mimics a paper document.

I fixed the directory name, but it still generates the same error.

If you already checked it, can you look at PHP logs? There definitely should be fatal errors associated with this issue. The relevant error should appear at the time you trying to access the plugins page.

Sorry I took so long to respond. I was on vacation. Looking at the error logs I see the following messages which correspond to the time period for when I tried to install the theme:

[29-May-2019 22:31:04 America/New_York] PHP Warning: PHP Startup: Unable to load dynamic library ‘/opt/cpanel/ea-php56/root/usr/lib64/php/modules/’ - /opt/cpanel/ea-php56/root/usr/lib64/php/modules/ cannot open shared object file: No such file or directory in Unknown on line 0
[29-May-2019 22:31:04 America/New_York] PHP Warning: Module ‘imagick’ already loaded in Unknown on line 0

This error means that imagick PHP module is loaded twice. But I don’t think this causes the problem. Can you look at the logs just after reproducing the problem? There should be a fatal error.

Hi I am facing sudden problem in Plugin Installed gallery
It is showing Loading and not

This problem occur when I try to upload a new plugin


Kindly inform the solution

Hi Sandeep,

Please check if you have duplicated the default plugin. If so, a problem like this occurs.
If there are no plugin duplications, you have to check any errors in your server PHP error log file, which might help you debug this issue!