Plugin Cited by for OJS 2.4.x


Hi everybody!
I’ve a short question - where can I get the current version of plugin Cited by (with crossref) for OJS 2.4.x…
Previous ( unfortunately, does not work.


Hi @karwas,

Your best bet is probably to contact the author of that plugin directly and ask if they’ve updated it for newer releases.

Alec Smecher
Public Knowledge Project Team


Hi @karwas

Any luck with regards to finding an updated Cited By Plugin (with crossref) for OJS 2.4.x. ?

Warm Regards


Hi @karwas and @cecile ,

change $doi = $article->getDOI(); for $doi = $article->getPubId(‘doi’);



Hi @alonsoj,
I change this but it seems that it still does not work.
Because there were a lot of posts I summarize.

  1. Here its my version this plugins: (with your change)
  2. I added entry {call_hook name=“citedby”} in /templates/article/article.tpl
  3. I send: CrossRef Cited-by Linking Registration

Could you check if the plug is correct? The plugin in your OJS works? Could you send a screenshot?


Hi @karwas:

I downloaded my plugin from and I did the change of $article->getDOI() to $doi = $article->getPubId(‘doi’) and {call_hook name=“citedby”} in templates/article/article.tpl

Have you tried this web:’.$user.’&pwd=’.$pass.’&doi=’.$doi.’&startDate=2007-01-01&endDate=2016-12-31 (with you own data - user,pass,doi)?

In my website is working.


I installed my plugin next one.
OJS version

But now… I see error.

I tried it also in OJS 3.0.0… but after installation in Plugins…loading, loading,

Any suggestions?


I’m using OJS, in OJS 3 i haven’t tested it yet but i think it should not work. Which version are you using?

Have you tested http://doi.crossref,org/servlet…to check your credentials are right?


Hmmm I think but not work…


That xml response is right for a non-cited DOI.

Can you test it with a cited DOI?


Success in OJS

But my platform ( is on OJS… here not working :frowning:


Maybe you should check your apache error log.



I try to install it in my ojs but the plugin didn’t show any settings to enter username password

It only has Enable/Disable link




Please any one help me on this,



@ Apacetech,

Have you solved this problem yet? I have problem same you.


HI you all.

My ojs ( is showing just one citation even if there is more citation inside xml.
Any ideas?

Tarcisio Pereira


145 function GetXML($doi, $user, $pass){
146 $xmlfile = ‘’.$user.’&pwd=’.$pass.’&doi=’.$doi.’&startDate=2007-01-01&endDate=’.date(‘Y’).’-12-31’;
147 $xmlparser = xml_parser_create();
149 // open a file and read data
150 $fp = fopen($xmlfile, ‘r’);
151 $xmldata = ‘’;
152 while (!feof($fp))
153 $xmldata .= fread($fp, 4096);
154 xml_parse_into_struct($xmlparser,$xmldata,$values);
155 xml_parser_free($xmlparser);

Working for me


A better one:

147 $xmlparser = xml_parser_create();
149 // New read xml
150 $ctx = stream_context_create(array(‘http’=>
151 array(
152 ‘timeout’ => 8, //Time in seconds
153 )
154 ));
155 $xmldata = file_get_contents($xmlfile, false, $ctx);
157 xml_parse_into_struct($xmlparser,$xmldata,$values);
158 xml_parser_free($xmlparser);