PKP PN Processing status stuck Unknown

Description of issue or problem I’m having:
Journal Identifier BE15DA08-B7F8-414A-B249-ADACAFC7047B

Although Local Status and Lockss Status change to “Transferred” and “Agreement” a few days after I click Reset for each issue to be deposited, the Processing Status has never changed from “Unknown”. I’ve tried this several times over the past months.

Steps I took leading up to the issue:

We enabled the plugin, have the php ziparchive installed, and have a journal identifier.

What I tried to resolve the issue:

I searched for other users in the forum having similar issues. Several mentioned specific warning or error messages they had found in their logs. I was unable to find similar ones on my servers. I also looked for general httpd and mysql messages.

We’ve tried reseting the the status of each issue a few times with no change. I did so on 7/13/21 (and again today).

Application Version - e.g., OJS 3.1.2:
OJS, PN version

Additional information, such as screenshots and error log messages if applicable:

We have multiple valid URLs for our journals with redirects/rewrites and I wonder if that might be an issue:, Texas Water Journal, and Texas Water Journal (and their http corresponding http versions).

Here are portions of relevant logs:

[2021-07-13 17:47:29] Texas Water Journal
[2021-07-13 17:47:29] [Notice] Task process started.
[2021-07-13 17:47:29] [Notice] PLN Depositor executeActions started
[2021-07-13 17:47:29] [Notice] Depositor processing for Texas Water Journal.
[2021-07-13 17:47:29] [Notice] Getting service document.
[2021-07-13 17:47:30] [Notice] Processing deposit status updates.
[2021-07-13 17:47:30] [Notice] Processing updated content.
[2021-07-13 17:47:30] [Notice] Processing new content.
[2021-07-13 17:47:30] [Notice] Packaging content for deposit.
[2021-07-13 17:47:30] [Notice] Trying package deposit 1 (Issue: 121) (Local Status: [New], Processing Status: [Unknown], Lockss Status: [Unknown])
[2021-07-13 17:47:41] [Notice] Packaging for deposit 1 succeeded

[2021-07-13 17:55:27] [Notice] Sending deposits to the PKP PN.
[2021-07-13 17:55:27] [Notice] Trying transfer deposit 1 (Issue: 121) (Local Status: [Packaged], Processing Status: [Unknown], Lockss Status: [Unknown])
[2021-07-13 17:55:27] [Notice] Posting the Atom file to staging server for deposit 1 (Local Status: [Packaged], Processing Status: [Unknown], Lockss Status: [Unknown]) - (Url: [], AtomPath: [/ebs/ojs/files/twj/journals/17/pln/06570B09-BA99-4F25-9735-CE4C8C838199/06570B09-BA99-4F25-9735-CE4C8C838199.xml], Method: [PostFile])
[2021-07-13 17:55:29] [Notice] Posting the Atom file to staging server for deposit 1 succeeded

[2021-07-13 17:55:41] [Notice] Task process stopped.

[2021-07-14 17:48:29] Texas Water Journal
[2021-07-14 17:48:29] [Notice] Task process started.
[2021-07-14 17:48:29] [Notice] PLN Depositor executeActions started
[2021-07-14 17:48:29] [Notice] Depositor processing for Texas Water Journal.
[2021-07-14 17:48:29] [Notice] Getting service document.
[2021-07-14 17:48:29] [Notice] Processing deposit status updates.
[2021-07-14 17:48:29] [Notice] Trying status update for 1 (Issue: 121) (Local Status: [Transferred], Processing Status: [Unknown], Lockss Status: [Unknown])
[2021-07-14 17:48:30] [Notice] Processing status got for 1 → (depositedByJournal)

[2021-07-14 17:48:34] [Notice] Processing updated content.
[2021-07-14 17:48:34] [Notice] Processing new content.
[2021-07-14 17:48:34] [Notice] Packaging content for deposit.
[2021-07-14 17:48:34] [Notice] Sending deposits to the PKP PN.
[2021-07-14 17:48:34] [Notice] Task process stopped.

NOTE: I have looked for Lockss status updates in the logs and not found any, I don’t know if this is expected or not.


Hi @laulandn,

How did you install the plugin? Can you confirm that it’s enabled? It looks like requests from the PKP|PN application to the journal for individual deposits is coming up with a 404 error.

Alec Smecher
Public Knowledge Project Team

Howdy Alec!

The plugin was part of the OJS 3.x package we downloaded (I didn’t do it so I don’t know the details), we only needed to enable it and fill in journal identifier.

Can you let me know what URL the PKP|PN application is trying to use to get to the individual deposits? I’m pretty confident that’s the issue. Our URLs are a bit of a mess, but if I can see which it’s trying to use, I can probably make it work.

Thanks a bunch!

Hi @laulandn,

I’ll PM you with a URL.


1 Like

FYI for those with similar issues: Its definitely that the journal isn’t responding to the urls the PN is using. I’ve been unable to find variations on them that are working (which I could then rewrite or redirect). This implies a problem with the plugin. I attempted removing it and all associated data from the database and filesystem, but that changed the journal id. Will followup.

Hi all,

One thing to check: Ensure that the base_url setting in your OJS configuration file is accurate. If it’s not, and you’re using CRON jobs to process scheduled tasks (including the PKP|PN task), you’ll end up sending incorrect URLs to the PKP|PN service.

Alec Smecher
Public Knowledge Project Team

It is now working perfectly! I don’t know what the issue was but removing everything related to the plugin from the database worked.

We’ve had some issues with the “versions” in the database not matching up to the actual plugin files in the filesystem. From what I determined it was to do with our upgrade process from 2.x which was a little kludgy.

It shouldn’t have been, but we had general problems with plugins. We have a custom repo/playbook which comes with a lot of things preconfigured/installed/setup since we run ~100 journals and had to upgrade them all. 90% of the upgrades were flawless, but the last 10% took a lot of time. Its not clear if we actually saved time in the long run, but I learned a LOT in the process. So, a bit painful, but likely worth it in the end.

Hi @laulandn,

Glad to hear it’s working!

FYI, we’re putting a lot of effort into reworking the upgrade process recently – this will include some new hurdles as we adopt some data-integrity database features we haven’t used in the past and may surface some previously-ignorable data problems, but within the next few releases (3.4 and 3.5) you should see a markedly faster, easier, and more reliable upgrade process. Our Technical Committee is also just finishing up some new upgrade documentation and would probably love to hear your feedback based on your own experiences – please watch for that!

Alec Smecher
Public Knowledge Project Team

This topic was automatically closed after 4 days. New replies are no longer allowed.