PKP PLN Plugin Error OJS

I have seen several forum topics about problems with the PKP PLN plugin, but I have encountered a problem that seems to be different than the normal problems that people have asked about.

I work for a private university and we run several journals from a single server,

When I log in as an administrator, I am greeted by a screen full of these messages saying “Notification There was an error connecting to the PKP PLN - please contact your system administrator.”


Most of our journals have gotten stuck in a common problem, where the Local Status shows Transferred by the Processing Status and LOCKSS Status show Unknown, as seen below for one of our journals:


For one of our journals, I tried testing something - I tried clicking on the Reset button for every issue to see if it would resend correctly. That was a couple weeks ago. Ever since, I have been bombarded by those Notifications every time I log in, and the Status page shows Local Status New, PRocessing Status and LOCKSS Status Unknown, as seen below:


I found this topic PKP PLN Status Question - #26 by esciencepress and checked to make sure we have Archive_Tar and yes, it is there. I also checked the version of PHP and it is much newer than 5.3.0 (I think it was 5.7 or 5.8, I don’t have access to it right at the moment) so that ruled out another possible problem. I also found the topic PKP PLN - Items not being deposited - #26 by mjoyce and checked to make sure base_url was set up correctly, and it seems to be, I think it pointed to the main page of

I have hit a wall and I am not sure what to try next. Any ideas would be greatly appreciated. Thanks.

I can see that you have six journals on the domain that have contacted the staging server. It looks like you’re running PHP 5.6 - I don’t think there was a 5.7 or 5.8.

Picking one at random, Revista Científica de Ciencias de la Salud has made 16 deposits. Volume 11, issue 1 was successfully processed, but the other ones weren’t.

You’re using https urls, and that’s good and something we encourage. But it looks like our staging server ran into an SSL certificate verification problem when it tried to download the zip package on 2018-07-05 at 00:00:21 PST.

I reset the deposits in our database so that the server will try to download them again. If it works tonight I’ll reset the deposits for your other journals as well.

Thank you @mjoyce for your help! I just checked the PKP PLN Plugin status for Revista Científica de Ciencias de la Salud, and it shows 1 issue as complete but the rest are still in Unknown, as shown below:


Do you think the other 15 issues will process eventually?

I know that the switch to https was relatively recent, and perhaps that is what is giving us problems. Any ideas on what we might need to change on our end to avoid that SSL certificate verification problem?

I like to test my SSL implementations with SSL Server Test (Powered by Qualys SSL Labs) it’s an incredibly thorough test. That’s about my complete knowledge of HTTPS - just test the heck out of it.

Your deposits downloaded just fine and are processing right now. It can take up to two weeks for them to make their way into all the LOCKSS boxes. I reset all your other journals as well - they should download and make their way into the network as well.

Ah excellent, so apparently whatever problem it was having before is working now since you say the deposits downloaded correctly. That is great news! I’ll keep you updated through this forum topic about the status of our journals in the PKP PLN.

Just a quick update about the status of a few of our journals, at least from what I can see.

Revista Científica Ciencias de la Salud
PKP PLN Plugin Status still shows Transferred but Unknown for all but the last issue.
However, the good news there is that in the list of journal issues available from there are 16 issues listed:
What’s more, The Keepers Registry page for the journal now shows 11 archives as of March 2:
So for this journal, I think things are more or less in order, despite the fact that the PKP PLN Plugin Status page hasn’t updated.

PKP PLN PLugin Status still shows New and Unknown for all 19 issues:
But the file from shows all 19 issues:
Unfortunately, The Keepers Registry does not show anything archived for this journal yet:
Is this just a matter of waiting for the next update between the PKP PLN and The Keepers Registry?

In total, 7 of our journals now appear in the latest list of journal issues available from

It looks like the PKP PLN Plugin Status page and The Keepers Registry are both taking some time to update, since both do not show these latest uploads to the PKP PLN.

@mjoyce Thank you again for your help, things seem to be moving forward, and hopefully with a little more time these other two pages will update with what now shows at