PHP Fatal error: web feed plugin

Hi @salman20054,

How did you install the custom block manager plugin? Is it possible that you’ve mixed code from OJS 3.1 in with code from another release?

Regards,
Alec Smecher
Public Knowledge Project Team

i collected that files from one of author in github an deposited in cpanel

Hi @salman20054,

Can you be more specific? Where exactly did you download it from?

Regards,
Alec Smecher
Public Knowledge Project Team

probably i forget the username but i got from github only
still have that plugin files with me

Hi @salman20054,

I suspect that you’re mixing incompatible versions of source code together. If possible, remove the version of the custom block manager plugin that you’ve installed, and install it again from within OJS’s Plugin Gallery.

Regards,
Alec Smecher
Public Knowledge Project Team

previously i tried i posted question also related to that in ojs plugin gallery after selecting install then after that the dialogue box open for confirmation when clicking on ok its doesn’t responds except cancel

Desktop%20screenshot%20(3)

Hi @salman20054,

What do you see in your error log when you try to install a plugin via the Plugin Gallery? Look for a message that contains the word “Error” in it; you can generally ignore warnings.

Regards,
Alec Smecher
Public Knowledge Project Team

[19-Mar-2018 19:57:24 UTC] PHP Warning: copy(https://github.com/pkp/translator/releases/download/ojs-3_1_0-0/translator-ojs-3_1_0-0.tar.gz): failed to open stream: no suitable wrapper could be found in /home/rubatosi/public_html/journal/lib/pkp/classes/file/FileManager.inc.php on line 159
[19-Mar-2018 19:57:24 UTC] ojs2: Incorrect MD5 checksum!

Hi @salman20054,

It looks like the allow_url_include option is turned off in your PHP configuration. You’ll need to change your PHP configuration to enable this.

Regards,
Alec Smecher
Public Knowledge Project Team

how to change allow_url_include option in php config it?

Hi @salman20054,

This will depend on your web server’s setup. It’s outside of OJS. You might need to check with your host for details.

Regards,
Alec Smecher
Public Knowledge Project Team

i gone through many sites regardin the allow_url_include at last i find this on my c panel that allow_url_include is on
Desktop%20screenshot%20(4)

even i changed the memory limit also based on this link: How to change the PHP runtime configuration from WHM? - Knowledgebase - AccuWebHosting

Hi @salman20054,

Something on your server is preventing PHP from using HTTPS URLs in the copy function. There are some additional PHP configuration suggestions on this StackOverflow thread.

Regards,
Alec Smecher
Public Knowledge Project Team

i tried but i dont know hoe to do so

Please anybody help me on this use

i downloaded the plugin from GitHub - pkp/customBlockManager at ec5838a0c601d75c86f6d72a0ed8ac9f0cd09bba

Hi @salman20054,

This is a PHP configuration problem, not an OJS configuration problem. You can try removing OJS from the equation by using the following test script:

<?php
ini_set('display_errors', E_ALL);
copy('https://github.com/pkp/translator/releases/download/ojs-3_1_0-0/translator-ojs-3_1_0-0.tar.gz', 'tmp.tgz');
if (file_exists('tmp.tgz')) echo 'It works.';
else echo 'It doesn\'t work.';

If this works, then the issue may be with OJS. If it doesn’t work, then you’ll need to adjust your PHP configuration. Another site like stackoverflow.com might be more helpful.

Regards,
Alec Smecher
Public Knowledge Project Team

Please check php.ini file on your server or ask administrator to help you in this regard.