OMP 3.1.2-4 Series editor doesn't see a discussion opened by a reviewer

Hi,

we are testing the review with OMP 3.1.2-4, in particular the discussion between a reviewer and his Series editor.
The reviewer is able to open a discussion and add a message to the Series editor, but the Series editor can’t see the discussion nor the message opened by the reviewer after the login.
Can anyone help?
Best regards
Elio

Hi,

I’m Elio’s collegue and I can add that even the press editor doesn’t see the discussion nor the messages added by a reviewer…
The editor receives email notifications but following the link doesn’t see the discussion after the login.
Any help is appreciated.
Best regards
Stefano

Hi @asmecher, can you tell us if this is a bug and give any help?
Best regards,
Stefano

Hi all,

OMP 3.1.2-4 is pretty old, so I’m hesitant to put too much time into debugging issues there… Could you try replicating the situation with the latest release to see if it still applies? (If you don’t want to spin up your own install, you could use the OMP testdrive installation that PKP hosts.)

Regards,
Alec Smecher
Public Knowledge Project Team

Hi Alec,
I followed your suggestion. On OMP testdrive I made a new submission: “Prova di pubblicazione”

  • Author: autore
  • Volume Editor: editor
  • Internal Reviewer: revisore
    As you can see Reviewer can add a message in Discussions, but Volume Editor (or Press Editor) cannot see this message.
    If I didn’t make a conceptual mistake, this can be a bug.

Thanks for help
Elio

Hi all,

Thanks, I’ve been able to track this down and file it here:

Please watch there for a fix.

Regards,
Alec Smecher
Public Knowledge Project Team