OJS3: Creating Volume number 0 in a migration project

Hi everyone,

we are new to OJS and the community. Our first project is to migrate hte existing journal http://www.rmm-journal.de/ to OJS3. We are currently preparing a XML-import but have a small problem with the volume number. The journal decided to begin its volume numbering with 0. I don’t know why they did it, but the editors want to preserve the data as it is so that citations are still valid.

When creating an issue with the volume number 0, there is an error in OJS that volume must be a positive numeric value und the issue cant be created. Do you have any ides for a workaround? Is it possible to somehow force OJS to use 0 as volume number. Or do you have another sugguestion how to handle the problem?

Hi @florianruckelshausen,

OJS (both 3.0 and 2.x) requires a volume number to be assigned to each issue, and forces the data to be numeric (so 0 if no volume number is entered). However, you can configure OJS not to display volume numbers if you don’t use them in your publication process. I’ve recently fixed a few places where OJS didn’t suppress volume/number information in accordance with the checkboxes – you may wish to apply the patch to your installation. It’s available here.

Alec Smecher
Public Knowledge Project Team

It sounds like the journal is using volume numbers, just indexed at zero instead of one.

Why shouldn’t null be used as the unassigned value instead of 0?

That’s right. The journal is using volume numbers and historically started with volume number 0 (instead of 1 as usual). We can’t change the numbering because the older volumes have already been published. Now the journal should be transfered to OJS because the old server will go offline.

When creating a new volume, i can disable the volume checkbox and don’t have to enter a volume number. But then OJS consequently doesn’t display a volume number after publishing it. The publishers want to preserve the bibliographic data as precise as possible. Is there a workaround that the volume number 0 (zero) is used and displayed?

Do you use both Volume/Number/Issue and Title? Have you tried a workaround of using identification by Title instead of Volummn/Number/Issue, and setting the Title to “Volume 0, Number 1”?

The journal just uses year and volume for identification. The Title field is more flexible and seems to be a good workaround. The first volume also seems to have been a bit special, so I will just disable the volume in this case and use the title instead. For the rest of the volumes (starting with 1) I think we can stay with the classical year+volume numbering.

Thank you.