OJS3.1.0.1 Plugins from Plugin Gallery do not get installed

Hi all,

I tried to install two plugins from the plugin gallery (Shariff and Custom Header Plugin) but nothing happens. The gallery states, that these plugins are not installed yet. When I click on one and click the ‘install’ button, I am asked in an additional popup, if I am sure that I want to install it. I click ok (the button looks like it is clicked) but then nothing happens. No ‘invalid JSON something’ warning or anything. Just nothing happens. The popup stays open and I can press the button as often as I want. The cancel button works and closes the popup. What could be the problem here?


We have the same problem, and I think that - in our case it has to do with the server platform. We are using Windows, and everything worked fine in OJS 2.x. Now it seems that we need to move to a Linux server to get it work.



we are running our OJS on an Ubuntu server, so it is not a Windows problem. It might be some rights settings on the server though, but since I do not have server access, I cannot check this or the server error log file.

Hi all,

The plugin gallery should work both in Windows and Linux, but you may have to configure some of the command-line tools it needs (e.g. tar) in config.inc.php. In any case, you will need to check your server’s error log to debug it. Hosts should always give you a way to access the log.

Alec Smecher
Public Knowledge Project Team