OJS Views Counts Stopped Working


I am using OJS from last 3 years, suddenly from Last October 2016, my views counts are stopped working

I review usage stat reports, but it also shows empty, Also in the database metric table, no entry form october

Recently I also upgrade OJS to, still no solution

I think there is some problem in Schedule Tasks XML files

URL: http://innovareacademics.in/journals/index.php/ijpps

Please Help

Hi @Editor_IJPPS

Hmmm… Could you please take a look in your usageStats folder in your files folder: are there any log files with the recent date i.e. since the counting stopped? Those log files would have the name like this: usage_events_YYYYMMDD.log. Maybe you could report everything you see in that folder.
Also, could you take a look in your scheduledTaskLogs folder in your files folder: There should be files with the name like this: Usagestatisticsfileloadertask-…-YYYYMMDD.log. If so, could you take a look at the most recent one, what it contains?


I have essentially the same problem with two journals CJC and SRC. The article views only report to 2014. In usage stats I can see the month of Feb 2015. I tried to generate a custom report and could see more recent files but nothing on article view. I don’t know where to find the scheduled tasks log but will try to find it.

Hi @RowlandLorimer

What OJS version are you using? Are there no recent entries in the DB table “metrics”? Do you see the recent log files in your files directory usageStats and if so in which subfolder? The scheduledTaskLogs folder is also in the files directory.
Are you using the Acron plugin or a cron job?


Thanks very much for the reply. You’re dealing with a non-techie so please be patient. I think we are operating with 2.8.1. I actually don’t know how even to assure myself of the version we are using. I don’t know how to get into our log tables only how to clear logs which is an option for journal managers. Can you tell me how to get to the files directory and the other files you are talking about? I did manage to see the headings “private files” and “public files” and went one step further but could not see the log files and “metrics.” In an attempt to find scheduledtasklogs I 2wne to “tiimed views” but I think that’s not the right rooute and when I asked for information nothing showed up. You will not be surprised to know that I have no idea if we are using an Acron plugin or a cron job. If this is all too much, please let me know.