[OJS/OMP-3.3.0-6] Galley name generated with the ID, not with the metadata name


Version 3.3.0-6 brings a change in the name of the galley, for example, if the ID of the galley is 240, when clicking on the PDF it will download a file called 240.pdf, if it is ID 560 then it downloads a file called 560.pdf.
Is this correct? Because with 3.3.0-5 this did not happen and in OMP it even downloads the file with the name I had named. Which was very convenient, instead of just having numbers.

Thank you.

Any idea about this @NateWr ?

Hi @dagosalas,

From 3.3, we are not modifying the filename when downloading it. The filename that is used is the filename when it was uploaded. However, files that were uploaded before 3.3 still have the automatically generated filename.

You can find more details in the discussion of this issue.

Thanks @NateWr ,
But something did happen, for example with omp 3.3.0-5 the PDF file when I uploaded it I put a name in the metadata, for example my_book.pdf, and so it was downloaded with that name (my_book.pdf).
But now with omp 3.3.0-6 it downloads a file named 173.pdf (where 173 is the ID of the galley), and for example I have to download a .mobi file, it only downloads a file named 9, without extension!!!.
The same happens with OJS3.3.0-6.
Check for example my OMP at El Topo Chico: su historia, su gente, sus manantiales | Libros UANL
and look at the file names when downloading.

Hi @dagosalas, I don’t get the same result. I see a full filename.


Hi @NateWr ,
I am testing with:

  1. Safari 14.1,
  2. Brave 1.24.84,
  3. Chrome v90.0.4430,
  4. Microsoft Edge 90.0.8
  5. Linux wget

and I keep getting a file named simply “9”.

And only with Firefox 88.0.1 I get a file named adminlibros,+El_topo_chico.mobi.

And previously (before v3.3.0-6) it worked fine in all browsers.
Any ideas?

@NateWr , I did a test by uploading a new book in three formats (pdf, epub and mobi), to check if the name change affected the new submissions or only the old ones.

And well yes, I got the same error, it downloads a file named with the galley ID number.
This is the submission I just made a few minutes ago.

Thanks @dagosalas, you’re right. This doesn’t seem to work correctly in several browsers. It is related to changes in 3.3.0-6 to better support diacritics and non-Latin characters in file download names, but it appears the response headers are not getting handled properly outside of Firefox.

I’ve reopened the issue and described the problem. You can follow that issue for updates.

1 Like

Thanks @NateWr , I will wait for this change and then I will validate another one in the Quicksubmit plugin that does not allow drag and drop of xml, html or CSS files to see if it’s related to this.

This topic was automatically closed after 6 days. New replies are no longer allowed.