[ojs] Is there a size limit on the Abstract metadata?

I encountered a very strange error using the OJS 2.4.5.

While updating the metadata for one published paper, I get the following error message:

403 Forbidden
You don't have permission to access /ojs/journal/editor/saveMetadata
on this server.
Additionally, a 404 Not Found
error was encountered while trying to use an ErrorDocument to handle the request.

This happens only with the abstract field. I can edit the rest of the fields with no problem.

Even stranger;
A) this error happens when I edit the 5th line of abstract forward!!! I can edit the first 5 lines of abstract and there is no problem. I copy-pasted the text into the note pas and removed all styling, etc, still the same problem. The text I am trying to add and gives error has 1171 characters.

B) I tried to copy-paste the problematic abstract text into another dummy paper abstract field (by editing its meta data in the same way). and it produced the same error there as well.

C) For B) I tried copypasting it another text, several time so that it made about 1580 chars, and it worked with no problem!!! the abstract was saved!

  1. any clue what is going on?
  2. Where are these meta data (e.g the keyword, abstract, etc) are stored? In Database? Which table/field? I am thinking if editing the abstract for this paper there.


Hi @Dani,

“Forbidden” messages are probably originating from your web server, not OJS; it’s likely that there is a mod_security rule in your Apache configuration that’s mistakenly thinking part of the article abstract is a hacking attempt, just based on its contents. Talk to your ISP and they should be able to identify the problematic rule.

Alec Smecher
Public Knowledge Project Team

1 Like

Dear sir, have u managed above problem ? if yes then how ?