OJS hangs when navigating to journal overview, issue view or when loading files

I am currently migrating old OJS and OMP installations to a new server. Everything worked fine until yesterday, when I reimported a more recent database dump.

  • OMP is still fine.
  • OJS suddenly loads forever when trying to navigate to a journal overview, an issue or the article views, without any error messages. The backend dashboard works fine.

One weird observation: If I deliberately mess up the files/ directory path (either changing the parameter in my config or by moving the directory), suddenly the journal overview and issue view load again, but of course PDFs and images are not found. One difference between both systems that might be relevant is the fact that the OJS installation still uses the legacy public directory for some older files.

Any suggestions/ideas how this could be happening? Is it a caching issue?

Hi @dersmon,

First, what’s your OJS version? Second: what do you mean by legacy public directory? That being said, I’d suggest to clean OJS cache and open the journal in a cache clean browser that you don’t usually use (I’m looking at you Edge and IE).


The version is

Concerning the public/ directory: Somehow I was under the impression that it was deprecated - but looks like I was wrong.

By cleaning the OJS cache you mean deleting the contents in cache/? That I already tried. I can reproduce the error across browsers and OS systems, so it seems to be something server related.

Quick update: The problem was a NFS mount, somehow PHP waited forever on a file lock release.