OJS build.js is not present in the stable branches?

Description of issue or problem I’m having:
build.js is not present in the stable branches.

Steps I took leading up to the issue:
I upgraded using the instructions at UPGRADE.md, following the steps which states

The official .tar.gz releases, and the stable branches in git (e.g. ojs-stable-3_1_1), contain precompiled javascript. If you are installing OJS using either of those and have not modified your Javascript, you do not need to compile Javascript.

I don’t see the js/build.js in any of the stable branches in ojs, is the documentation out of date, or is the js included in one of the other the minified files?

What I tried to resolve the issue:
When I merged with stable-3-3-0, and also copied the build.js from the official tar download, the UI worked again.

Application Version - e.g., OJS 3.1.2:
From 3.1 to (merge-with) stable-3_3_0

Additional information, such as screenshots and error log messages if applicable:

Hi @OyvindLGjesdal

build.js is created when the npm install/run build commands are run. It’s not included in the stable branches because those are dev branches and it’s assumed that if you are working with them you’ll generate the build file yourself. If the docs say that the build.js file is included then yeah, it’s probably out of date.