OJS 3 problems with translation

I am working on a Slovenian localization for the OJS 3. More or less the localization already works. but now I got to the point I am lost a little bit:

  • I manually change a localized string in .xml file (there was a typo) and save it
  • I don’t get that changed string into UI
  • I tried with browser reload and Clear Template Cashe and manually removing all files in the cache directory

But nothing helps. The UI shows the old string with the typo. I don’t know, that worked in OJS 2, so must be I am missing something new for OJS 3. Right? Any hint?

Regards, Primož

Do you use plugin for translation? Some stringsare identical but relate to different parts of interface. It could happen that some message key is left untranslated.
However, delete cache a couple of times in OJS and browser since something may beleft in OJS and/or your browser.

Hi @vvucic,

I am not using the plugin. I am modifying .xml files directly with an editor. I am aware of same string being in many .xml files. However I am checking with a search tool to verify there is no such string in .xml files, clearing templates cache several times, reloading browser several times, but it simply doesn’t work.

Best regards, Primož

I think that in version 3.1 some keys are missing. Please search forum regading that issue.

Hi @vvucic

Actually I have OJS Let me show you the concrete example. I changed “Author” in the list of user roles to “Avthor”:
But there is a typo and should be “Avtor”. If I search in the whole OJS directory structure, there is no “Avthor”. So I can not fix it. Any idea?

Best regards, Primož

You have to check in folders

Did you check in all of them?

Jp, I have checked all the “localization” subdirectories as well as the whole OJS subdirectory tree.

Best regards, Primož

In my experience cache emptying is not always good. So, do it a cople of times or enter the chace folder and in t_compile delete all .php files. DO not delete subfolders in /cache.
After that empty all cache in browser and try again.

Hi all,

Some locale keys are installed from the .xml files into the database when the journal is created. Try creating another journal and you should see the newer values from the .xml file installed there.

Alec Smecher
Public Knowledge Project Team

1 Like

Hi @asmecher,

That is it: The problematic string “Author” has been hiden in the DB table user_group_settings. Changing it helped.
Thank you.

Best regards, Primož