OJS 3 problem - Authors name not in Submission list

Hello forum,
I’m having an issue in the OJS3 backend:
In the Submission section, there’s the list of the articles (I did an import/export via mysql from a previous OJS version). But the authors are not displayed.
Can you tell me what could be the problem?

Hi @Giulio_Anesa,

Did you do some kind of manual conversion from OJS 2.x to 3.x?

Alec Smecher
Public Knowledge Project Team

Yes I did everything manually via mysql, 'cause the upgrade process doesn’t work properly with my installation.
So I create a new ojs 3 and added all the mysql tables one by one…
The cms works, but I can’t see the authors. Can u help me?

Hi @Giulio_Anesa,

It’s very likely that there’s a data integrity issue caused by the manual upgrade. That’s a complex process and I doubt we’re going to document/support it outside the existing script. What was the problem you were having with the upgrade script?

Alec Smecher
Public Knowledge Project Team

Dear @asmecher,
I have same problem, upgrade manually from 2.4.8 to 3.0.2
there are no submission listed in left menu submission at “my queue” if role as author
i think data integrity issue caused by the manual upgrade cause i upgrade one by one in mysql data, but i dont know where data related

if i login by role as jurnal manager,
there are 16 items submission listed in “task menu”,
but only 1 item submission listed in Unassigned in tab “my queue”,
and same item in tab “all active”

i’m very confuse to solve this in mysql data, please help me

Hi @edhy,

Is it an option to return to your OJS 2.x installation and re-run the upgrade script? It’ll be hard for us to support manual upgrades as the upgrade process is very complex and you’re likely to miss important pieces that will be difficult to debug remotely.

Alec Smecher
Public Knowledge Project Team

thanks for your attention.

im forget to backup database ojs 2.x.
i tried to downgrade, but system can’t support this,

so i install fresh ojs 3, i copying one by one table from old databse (upgraded) to new database

i think there is no choice: get find missing value in database or submit the submission from early.

i solve why there is only 1 item in unsigned as role editor,
value of submission_id in “author” not same with submission_id in submissions, submission_file_settings,submission_files, submission_settings

submission_id in “author” have old value data.

submission_id in submission_id in table submissions, submission_file_settings,submission_files, submission_settings is restart from 1

so, I change the value of the table submissions according to the continued value in table “authors”

the result are:
#1. 16 items displayed in unsigned section in tab “my queue”,
also displayed 16 items in tab “All active”

#2. displayed “16” beside tab “tasks”, just loading icon when clicked, no data loaded

#3. i try to download doc of submission file, its become 500 Internal Server Error.
may be error with path of file location, isn’t?

#4. still no listed submission in “my authored”
solved by i add manual participant (the author) of submission, still no submission files to download

what is your suggestion?

Hi @edhy,

I’d suggest using the debug option in config.inc.php to dump SQL queries to the browser as they’re executed. That way you can look for a query that makes use of the authors table on a page where the authors aren’t being listed, and see what the expectations of the database are, working through the joins as necessary to find out what expectation the data isn’t meeting.

Alec Smecher
Public Knowledge Project Team