[OJS 3] Plugins Tab doesn't load

PS. Console says this: Failed to load resource: the server responded with a status of 500 (Internal Server Error)

Hi @filipi

Try to click on the error that is showing in console and verify which resource give you error 500, perhaps it helps to isolate the problem.

Israel

Hi @israel.cefrin, I’m afraid I have no idea what to do. I am not a developer. Shouldn’t this be a user friendly software? I don’t have a PhD in computer science. I tried everything and I do not know how to fix it. The error seems to point to Google Scholar Indexing Plugin.
http://akropolis.helenskestudije.me/OJS/index.php/ajhs/$$$call$$$/grid/settings/plugins/settings-plugin-grid/fetch-grid?_=1506359394770#

PS. Now that I tried again, it points to another plugin HTML Article Galleys:
http://akropolis.helenskestudije.me/OJS/index.php/ajhs/$$$call$$$/grid/settings/plugins/settings-plugin-grid/fetch-grid?_=1506362655611

The php error log that I see says:
[25-Sep-2017 18:04:26 UTC] PHP Warning: file_exists(): open_basedir restriction in effect. File(/OJS/js/pkp.min.js) is not within the allowed path(s): (D:/INETPUB/VHOSTS/helenskestudije.me;C:\Windows\Temp) in D:\INETPUB\VHOSTS\helenskestudije.me\akropolis.helenskestudije.me\ojs\lib\pkp\classes\template\PKPTemplateManager.inc.php on line 599
But I am not sure if this is connected to this issue.

The error says File(/OJS/js/pkp.min.js), this is an attempt to access your server root folder.
Perhaps it is related with this thread (the error message is similar):

I don’t think this is related. Even if it was, not sure how to fix it.

In that thread there’s a hint how to fix it.
Verify in your config.inc.php parameter base_url, for example.

Or try patching with instructions on this issue topic:

Best

Israel

No, this doesn’t help. Many things are simply not working. Plugins are not loading, who know why, and then, I can’t upload any single image to site, including journal logo. It says No file uploaded or invalid file type, and I was trying to upload both jpg and png files. I really do not know what to do. Is there a way to uninstall the entire thing and try with OJS 2?

Fortunately, we haven’t started publishing the journal or receiving submission, so uninstall would do no harm.

When a file can’t be uploaded in the most of time is a permission setting issue. But, just in case, have you checked your webserver log? You need set read and write permissions when you install any software with root privileges (I don’t know if it’s your case).

To uninstall OJS is just enough erase all files and empty database. But OJS 2, as posted here:

It(OJS2) will continue to receive minor translation updates, bug fixes, and particularly security updates, at least through 2016 and 2017

So, I recommend OJS3, or consider that any layout(HTML/CSS/JS) or functionalities adaptation you’ve code in OJS2 you will need be do it again when you migrate to latest version.

Israel

I see… Ok, thanks for the info.
PS. I checked the permissions, everything seems to be in order with that…

Hi,
error

error log

[10-Feb-2018 11:43:18 UTC] PHP Strict Standards: Declaration of DRIVERDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/eleyon/public_html/journals/plugins/generic/driver/DRIVERDAO.inc.php on line 19
[10-Feb-2018 11:43:18 UTC] PHP Strict Standards: Declaration of OpenAIREDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/eleyon/public_html/journals/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 100
[10-Feb-2018 11:43:18 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getSeq() should be compatible with BlockPlugin::getSeq($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:18 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getBlockContext() should be compatible with BlockPlugin::getBlockContext($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:18 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getEnabled() should be compatible with BlockPlugin::getEnabled($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:18 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getContents() should be compatible with BlockPlugin::getContents($templateMgr, $request = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:20 UTC] PHP Strict Standards: Declaration of DRIVERDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/eleyon/public_html/journals/plugins/generic/driver/DRIVERDAO.inc.php on line 19
[10-Feb-2018 11:43:20 UTC] PHP Strict Standards: Declaration of OpenAIREDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/eleyon/public_html/journals/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 100
[10-Feb-2018 11:43:20 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getSeq() should be compatible with BlockPlugin::getSeq($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:20 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getBlockContext() should be compatible with BlockPlugin::getBlockContext($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:20 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getEnabled() should be compatible with BlockPlugin::getEnabled($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:20 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getContents() should be compatible with BlockPlugin::getContents($templateMgr, $request = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:30 UTC] PHP Strict Standards: Declaration of DRIVERDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/eleyon/public_html/journals/plugins/generic/driver/DRIVERDAO.inc.php on line 19
[10-Feb-2018 11:43:30 UTC] PHP Strict Standards: Declaration of OpenAIREDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/eleyon/public_html/journals/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 100
[10-Feb-2018 11:43:30 UTC] PHP Strict Standards: Declaration of ContextSettingsForm::fetch() should be compatible with Form::fetch($request, $template = NULL, $display = false) in /home/eleyon/public_html/journals/lib/pkp/classes/controllers/tab/settings/form/ContextSettingsForm.inc.php on line 20
[10-Feb-2018 11:43:30 UTC] PHP Strict Standards: Declaration of ContextSettingsForm::initData() should be compatible with Form::initData() in /home/eleyon/public_html/journals/lib/pkp/classes/controllers/tab/settings/form/ContextSettingsForm.inc.php on line 20
[10-Feb-2018 11:43:30 UTC] PHP Strict Standards: Declaration of ContextSettingsForm::readInputData() should be compatible with Form::readInputData() in /home/eleyon/public_html/journals/lib/pkp/classes/controllers/tab/settings/form/ContextSettingsForm.inc.php on line 20
[10-Feb-2018 11:43:30 UTC] PHP Strict Standards: Declaration of ContextSettingsForm::execute() should be compatible with Form::execute() in /home/eleyon/public_html/journals/lib/pkp/classes/controllers/tab/settings/form/ContextSettingsForm.inc.php on line 20
[10-Feb-2018 11:43:30 UTC] PHP Strict Standards: Declaration of PKPAppearanceForm::fetch() should be compatible with ContextSettingsForm::fetch($request, $params = NULL) in /home/eleyon/public_html/journals/lib/pkp/controllers/tab/settings/appearance/form/PKPAppearanceForm.inc.php on line 18
[10-Feb-2018 11:43:31 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getSeq() should be compatible with BlockPlugin::getSeq($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:31 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getBlockContext() should be compatible with BlockPlugin::getBlockContext($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:31 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getEnabled() should be compatible with BlockPlugin::getEnabled($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:31 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getContents() should be compatible with BlockPlugin::getContents($templateMgr, $request = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::getUserVar() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/form/Form.inc.php on line 388
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/core/PKPRequest.inc.php on line 592
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::getUserVar() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/form/Form.inc.php on line 388
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/core/PKPRequest.inc.php on line 592
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::getUserVar() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/form/Form.inc.php on line 388
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/core/PKPRequest.inc.php on line 592
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::getUserVar() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/form/Form.inc.php on line 388
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/core/PKPRequest.inc.php on line 592
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::getUserVar() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/form/Form.inc.php on line 388
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/core/PKPRequest.inc.php on line 592
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::getUserVar() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/form/Form.inc.php on line 388
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/core/PKPRequest.inc.php on line 592
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::getUserVar() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/form/Form.inc.php on line 388
[10-Feb-2018 11:43:31 UTC] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/core/PKPRequest.inc.php on line 592
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of DRIVERDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/eleyon/public_html/journals/plugins/generic/driver/DRIVERDAO.inc.php on line 19
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of DRIVERDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/eleyon/public_html/journals/plugins/generic/driver/DRIVERDAO.inc.php on line 19
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of OpenAIREDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/eleyon/public_html/journals/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 100
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of OpenAIREDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/eleyon/public_html/journals/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 100
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getSeq() should be compatible with BlockPlugin::getSeq($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getBlockContext() should be compatible with BlockPlugin::getBlockContext($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getEnabled() should be compatible with BlockPlugin::getEnabled($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getContents() should be compatible with BlockPlugin::getContents($templateMgr, $request = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getSeq() should be compatible with BlockPlugin::getSeq($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getBlockContext() should be compatible with BlockPlugin::getBlockContext($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getEnabled() should be compatible with BlockPlugin::getEnabled($contextId = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 11:43:34 UTC] PHP Strict Standards: Declaration of CustomBlockPlugin::getContents() should be compatible with BlockPlugin::getContents($templateMgr, $request = NULL) in /home/eleyon/public_html/journals/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 134
[10-Feb-2018 12:20:36 UTC] PHP Fatal error: Call to a member function getSetting() on null in /home/eleyon/public_html/journals/pages/information/InformationHandler.inc.php on line 88
[10-Feb-2018 14:52:10 UTC] PHP Fatal error: Call to a member function getSetting() on null in /home/eleyon/public_html/journals/pages/information/InformationHandler.inc.php on line 88
[10-Feb-2018 16:07:57 UTC] PHP Fatal error: Call to a member function getSetting() on null in /home/eleyon/public_html/journals/pages/information/InformationHandler.inc.php on line 88

last error log page in my journals please anyone to help me how to fix

[11-Feb-2018 08:33:11 UTC] PHP Deprecated: Non-static method Config::getContextBaseUrls() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/core/Core.inc.php on line 313
[11-Feb-2018 08:33:11 UTC] PHP Deprecated: Non-static method Core::removeBaseUrl() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/plugins/generic/usageStats/PKPUsageStatsLoader.inc.php on line 508
[11-Feb-2018 08:33:11 UTC] PHP Deprecated: Non-static method Core::_getBaseUrlAndPath() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/core/Core.inc.php on line 256
[11-Feb-2018 08:33:11 UTC] PHP Deprecated: Non-static method Config::getContextBaseUrls() should not be called statically, assuming $this from incompatible context in /home/eleyon/public_html/journals/lib/pkp/classes/core/Core.inc.php on line 313

and i have checked in my website inspected internel server error 500

Hi @vigneshabimanyu

Those Deprecated and Strict Standards messages are not important.
What OJS version are you using?
What exactly are you trying to do, where and as what user?

Best,
Bozana

Dear @bozana,

Thank you very much for your response. Currently, I am using OJS 3.1.0.1 version. I am trying to install plugins for my journal but I am unable to do it. When I open the inspect page it displays an error message like "Failed to load resource: the server responded with a status of 500 (Internal Server Error)". I kindly request you to help me in this regard. 

Sorry to disturb you

Among cosmetic warning, there was a fatal error also:

[10-Feb-2018 12:20:36 UTC] PHP Fatal error: Call to a member function getSetting() on null in /home/eleyon/public_html/journals/pages/information/InformationHandler.inc.php on line 88

Hi all,

That error suggests that the journal is missing – journal object seems to be null – but I do not understand how this could be possible at the plugin gallery page :open_mouth: Thus is this the error that happens exactly when you press “OK” (to install the plugin)? When I try to install that plugin AddThis from the plugin gallery everything works just fine and I have no error, thus I do not know what is happening there :frowning:
@vigneshabimanyu, do you maybe have any unusual installation or server configuration or… ?

Best,
Bozana

Hi all,
In OJS 3.1.1. Plugins Tab doesn`t load.
Tab%20plugin
In error.log received a lot of like>
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of DRIVERDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/stranip/public_html/plugins/generic/driver/DRIVERDAO.inc.php on line 0
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of ArticleHandler::initialize() should be compatible with PKPHandler::initialize($request) in /home/stranip/public_html/pages/article/ArticleHandler.inc.php on line 0
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Warning: Smarty error: unable to read resource: "file:0/plugins/generic/usageStats/templates/outputFrontend.tpl" in /home/stranip/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/Smarty.class.php on line 1094
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of PKPUsageEventPlugin::getEnabled() should be compatible with LazyLoadPlugin::getEnabled($contextId = NULL) in /home/stranip/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 24
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Deprecated: Non-static method PKPRequest::getBaseUrl() should not be called statically, assuming $this from incompatible context in /home/stranip/public_html/lib/pkp/plugins/generic/usageStats/PKPUsageStatsPlugin.inc.php on line 436
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/stranip/public_html/lib/pkp/classes/core/PKPRequest.inc.php on line 158
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of LensGalleyPlugin::register() should be compatible with LazyLoadPlugin::register($category, $path, $mainContextId = NULL) in /home/stranip/public_html/plugins/generic/lensGalley/LensGalleyPlugin.inc.php on line 0
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of AddThisPlugin::register() should be compatible with LazyLoadPlugin::register($category, $path, $mainContextId = NULL) in /home/stranip/public_html/plugins/generic/addThis/AddThisPlugin.inc.php on line 0
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of SubmissionFileDAO::fromRow() should be compatible with PKPSubmissionFileDAO::fromRow($row, $fileImplementation) in /home/stranip/public_html/classes/article/SubmissionFileDAO.inc.php on line 23
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Deprecated: Non-static method PKPApplication::getCCLicenseBadge() should not be called statically, assuming $this from incompatible context in /home/stranip/public_html/pages/article/ArticleHandler.inc.php on line 150
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of SubmissionKeywordEntryDAO::getByControlledVocabId() should be compatible with ControlledVocabEntryDAO::getByControlledVocabId($controlledVocabId, $rangeInfo = NULL, $filter = NULL) in /home/stranip/public_html/lib/pkp/classes/submission/SubmissionKeywordEntryDAO.inc.php on line 20
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of CustomBlockPlugin::getBlockContext() should be compatible with BlockPlugin::getBlockContext($contextId = NULL) in /home/stranip/public_html/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 0
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of CustomBlockPlugin::getEnabled() should be compatible with BlockPlugin::getEnabled($contextId = NULL) in /home/stranip/public_html/plugins/generic/customBlockManager/CustomBlockPlugin.inc.php on line 0
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of OpenAIREDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/stranip/public_html/plugins/generic/openAIRE/OpenAIREDAO.inc.php on line 19
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of DRIVERDAO::setOAI() should be compatible with PKPOAIDAO::setOAI($oai) in /home/stranip/public_html/plugins/generic/driver/DRIVERDAO.inc.php on line 0
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of ArticleHandler::initialize() should be compatible with PKPHandler::initialize($request) in /home/stranip/public_html/pages/article/ArticleHandler.inc.php on line 0
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Deprecated: Non-static method Config::getContextBaseUrls() should not be called statically, assuming $this from incompatible context in /home/stranip/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 199
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of SubmissionFileDAO::fromRow() should be compatible with PKPSubmissionFileDAO::fromRow($row, $fileImplementation) in /home/stranip/public_html/classes/article/SubmissionFileDAO.inc.php on line 23
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Deprecated: Non-static method PKPApplication::getCCLicenseBadge() should not be called statically, assuming $this from incompatible context in /home/stranip/public_html/pages/article/ArticleHandler.inc.php on line 150
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Strict Standards: Declaration of SubmissionKeywordEntryDAO::getByControlledVocabId() should be compatible with ControlledVocabEntryDAO::getByControlledVocabId($controlledVocabId, $rangeInfo = NULL, $filter = NULL) in /home/stranip/public_html/lib/pkp/classes/submission/SubmissionKeywordEntryDAO.inc.php on line 20
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Warning: Smarty error: unable to read resource: "file:0/plugins/generic/usageStats/templates/outputFrontend.tpl" in /home/stranip/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/Smarty.class.php on line 1094
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Deprecated: Non-static method PKPRequest::getBaseUrl() should not be called statically, assuming $this from incompatible context in /home/stranip/public_html/lib/pkp/plugins/generic/usageStats/PKPUsageStatsPlugin.inc.php on line 436
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/stranip/public_html/lib/pkp/classes/core/PKPRequest.inc.php on line 158
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Deprecated: Non-static method Config::getContextBaseUrls() should not be called statically, assuming $this from incompatible context in /home/stranip/public_html/lib/pkp/plugins/generic/usageEvent/PKPUsageEventPlugin.inc.php on line 199
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Warning: Smarty error: unable to read resource: "file:0/plugins/generic/usageStats/templates/outputFrontend.tpl" in /home/stranip/public_html/lib/pkp/lib/vendor/smarty/smarty/libs/Smarty.class.php on line 1094
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Deprecated: Non-static method PKPRequest::getBaseUrl() should not be called statically, assuming $this from incompatible context in /home/stranip/public_html/lib/pkp/plugins/generic/usageStats/PKPUsageStatsPlugin.inc.php on line 436
[23-Oct-2018 11:27:18 Europe/Belgrade] PHP Deprecated: Non-static method PKPRequest::_checkThis() should not be called statically, assuming $this from incompatible context in /home/stranip/public_html/lib/pkp/classes/core/PKPRequest.inc.php on line 158

How to solve that?
Thanks
Lazar

Hi @Lazar_Stosic

What version exactly are you using and how did you install it (using a package or Git)?

Thanks!
Bozana

Hi @bozana
I am using OJS 3.1.1.0. I installed this version a couple a months ago and everything work well. Now, in new issue need to add DOI numbers but when I tried to activate this option in Tab Plugins I received this problem. From some reason I cannot insert in this Tab. I install it regularly, full zip on the server, unpack, install without problem, add plugins which I need but after a couple of months now I cannot do that.
Thank you in advance.
Lazar