OJS 3.3 Native Import for articles not working

Describe the bug
I am trying to do a Native Import of articles from OJS to 3.3.0-13 but is giving me an error even if I it is a single submission.

To Reproduce
Steps to reproduce the behavior:

  1. Go to Tools > Native XML Plugin > Import (tab)’
  2. Click on ‘Upload a file’ or drag and drop a submission XML format file
  3. Click ‘Import’ button
  4. See error

What application are you using?
OJS version 3.3.0-13

Additional information
Since the forum will not allow me to attach the XML file I will share the XML import file link from our pCloud drive;


Hi @drycko

You cannot use the native import plugin to move content between OJS versions. Both installations must be using the same version since the database schema is mirrored in the XML and the schemas change between versions of OJS.


Hi @jnugent
That explains it, thank you for your feedback.

So I ended up going the long way to get a better result.

So this is what we did;

Moved the old install to https://ojs.domainname.co/v3211

We decided to install the latest version (with it’s own database) on the main directory/URL - https://ojs.domainname.co/

The old database stays untouched, because we are still having the charset issue we had last year when we tried to upgrade to the latest version

To fix the charset issue on the new installation we will have to copy the text from the old install and edit in the new instance. We have went ahead and edited the text int the Journal Settings the same way.

Our journal has over 600 articles so going the find and replace route of the SQL file did not really work.

Hi @drycko

It’s probably worth investigating why you had character set issues when you tried to upgrade the last time. It’s possible a configuration setting changed and you didn’t realize it. OJS does not normally alter character sets if the settings remain the same between versions.