OJS First admin login failed after success installation : PHP error GuzzleHttp ConnectException

After finishing the install process of an ojs instance and log in with admin credential, i’m redirected to blank page http://localhost/index.php/index/admin/contexts
only profile page work fine : http://localhost/index.php/index/user/profile
php log file show a PHP FATAL ERROR:

[07-Mar-2021 13:13:02 UTC] PHP Fatal error: Uncaught GuzzleHttp\Exception\ConnectException: cURL error 7: (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) in /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php:200
Stack trace:
#0 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(155): GuzzleHttp\Handler\CurlFactory::createRejection()
#1 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(105): GuzzleHttp\Handler\CurlFactory::finishError()
#2 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlHandler.php(43): GuzzleHttp\Handler\CurlFactory::finish()
#3 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/Proxy.php(28): GuzzleHttp\Handler\CurlHandler->__invoke()
#4 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/Proxy.php(51): GuzzleHttp\Handler\Proxy::GuzzleHttp\Handler{closure}()
#5 /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/PrepareBodyMiddleware.php(37): GuzzleHttp\Handler\Proxy::GuzzleHttp\Handler{closure} in /var/www/html/lib/pkp/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 200

Hi @BessemAamira,

Is your server firewalled from contacting pkp.sfu.ca? It’ll be necessary to permit OJS to contact pkp.sfu.ca to check for updated versions and compatible plugins. (If you need to set up a proxy, it can be configured in config.inc.php.)

Alec Smecher
Public Knowledge Project Team

Good Evening,

My server is our DMZ and prevents any outbound connections. Can I somehow disable my OJS install to connect to pkp.sfu.ca as I cannot open the Administration page


Hi @daanlessing,

To turn off outgoing connections from OJS to the PKP server, turn off enable_beacon and show_upgrade_warning in config.inc.php.

There are other outgoing connections you may need, e.g. for CrossRef deposits; if you have a proxy, you can configure it in config.inc.php.

Alec Smecher
Public Knowledge Project Team

Hi asmecher and all.

Our test server (private network) is suffering the same problem after the installation from to
Setting the show_upgrade_warning variable resolved the problem but i tried also to set proxy parameter without much success.

http_proxy = “http://proxy.xxx.yy:8080
https_proxy = “http://proxy.xxx.yy:8080

GuzzleHttp complains very much. Do you know the right string for proxy conf ? i read/tried also tcp://proxy.xxx.yy:8080 …

Best regards,

In my case, It was due to the Selinux mode. To fix/debug this issue, you can switch selinux to permissive mode

1 Like