OJS 3.3.0.10 Unrecognized authorization header

Hi, I just upgraded from to OJS 3.3.0.10 and am seeing this error. Has anyone else seen this error?

Description of issue or problem I’m having:
When I login and go to the submission page, I see this error:

##An unrecognized Authorization header was received. Expected to receive "Authentication: Bearer ".##

While it lets me log in to my account (journal manager level), it doesn’t show me anyone else’s submissions, either active or archived.

Steps I took leading up to the issue:

I have just upgraded from OJS 3.3.0.6 to 3.3.0.10, and then logged in. The error appears on first login (because you end up at submissions). It also appears if I go back to the submissions page after being elsewhere.

What I tried to resolve the issue:

I have tried checking my server logs but can’t see anything in my nginx access or error logs.

Application Version - e.g., OJS 3.1.2:

OJS 3.3.0.10
Server: CentOS 7
PHP: 7.4.28
Server: nginx/1.20.1 + php-fpm
Database driver: mysql
Database: 5.5.5-10.3.34-MariaDB

Additional information, such as screenshots and error log messages if applicable:
error-message

No idea what changed, but it seems to be working now?

This topic was automatically closed after 6 days. New replies are no longer allowed.