[OJS] Portico plugin not transfering via FTP


We’re running OJS and want to use the portico plugin. Installation worked fine, but we’re running into the following issue:
When trying to “Deposit Issues” (only 1 issue selected for testing), we get this error displayed in OJS:
Unable to write file at location: [JOURNALNAME]_batch_2022-02-14-07-08-54.zip. writing the file failed

When we try to “Export Issues”, we get a download of a perfect working zip file, containing all articles correctly.

Checking the PHP error log, we get this error:

[...] PHP Warning:  ftp_fput(): php_connect_nonb() failed: Operation now in progress (115) in /plugins/importexport/portico/vendor/league/flysystem/src/Ftp/FtpAdapter.php on line 159
[...] PHP Warning:  ftp_fput(): Command ok : Binary type selected. in /plugins/importexport/portico/vendor/league/flysystem/src/Ftp/FtpAdapter.php on line 159

So there must be an error, when OJS tries to send the file with FTP to Portico.

Connecting with the Portico FTP credentials with a FTP client (FileZilla) works as expected.

Can somebody please help?

@asmecher Am I right, that this is you maintaining the plugin?


Hi @twa,

In my experience with FTP this is due to firewalls interfering with connections between the client and server; it can be worked around by putting the FTP connection into passive (PASV) mode, but that would take an additional line of code in the plugin. I think you could avoid having to do that by just using SFTP instead of FTP.

Alec Smecher
Public Knowledge Project Team

This topic was automatically closed after 6 days. New replies are no longer allowed.