OJS [3.1] Login is no wroking

Hi all, sorry to be a bother again.

I am still struggling with my OJS 3.1 installation.
I managed to create a new server with the last php version and I ran the update script with success!!!

But now I cannot login in the system any more, the browser display a ERR_TOO_MANY_REDIRECTS error. Please try yourself http://ojs3.equinoxpub.com
I tried to clean the cache obviously but with no success.

I had a look at the logs and there is no errors in the log. Everything looks ok to me.

Can someone please help me? Do you have any idea about this problem?

Thanks in advance.

Hi @marcello8080

How does your DB table custom_issue_orders looks like? – You have used the “Order” function to reorder the issues, or?


Hi @bozana thanks for your answer,

Table custom_issue_orders and table and table custom_section_orders are empty. I am testing the last version of OJS so we haven’t inserted too many information for now, only the journals with the journal descriptions and journal banner.

Any idea?

I fixed this,

Apparently the plugin Shibboleth Authentication Plugin hasn’t been installed properly and it crashed. I had to disable this plugin through the database and now the login system is working properly again.

Here is the query
UPDATE plugin_settings SET setting_value='0' WHERE plugin_name='shibbolethauthplugin' and context_id ='0' and setting_name ='enabled';

Hope this can be helpful for someone else, I have seen that this problem appears few times in the forum.


Ah, sorry @marcello8080, I somehow managed to answer in the wrong post, I actually wanted to post my last questions to this topic: OJS 3.1.1. The order of issues is constantly changing - #3 by OSU :open_mouth:
Sorry :frowning:

It’s ok, I am happy I found the solution anyway. Are you able to explain why the plugin Shibboleth Authentication Plugin didn’t work anymore and how the configuration works?


Hi @marcello8080

Ah, I am not so familiar with the Shibboleth plugin, but maybe @crism could help?


I am using the Shibboleth plugin with OJS 3.1… What version did you upgrade from, @marcello8080?

Hi @crism
I update from Ojs 3.0.2 to the last ojs 3.1.1.

I think the problem is not related with the updating of the system but with the installation of the plugin.
I probably didn’t install the plugin in the proper way

Try a clean install from the plugin gallery… see how it goes. If you still have problems, report your settings and any errors in your server log.

The problem didn’t generate any errors in the logs, only warnings.
I deactivated the plugin (querying the database) and now the login works properly again, but the plugin setting is still in the database and the plugin folder is still in the server. I need to deeply delete the plugin before reinstall it again, but I have no idea how to do it.