OJS-3.1.2 blank panel: permission denied

I recently opened two topics that helped me find the error. Now I need help to correct it.

Note, I installed ojs-3.1.2, but when I try to access the panel / installation page for the first time, a completely blank page appears.

Using the find / -name php.ini command in ubuntu, the permission error denied (I was going to paste here but exceeded the character limit). Well, I have no idea how to go about fixing this.
The permissions are with 0770 and 2770, and www-date for cache and upload folder.
I wear:

php 7.2
mysql 5.7
apache 2
ubuntu 18.04

Hi @Alison_Henrique_Mach,

Can you check if web root content is readable for apache (www-data user)?

1 Like

@Vitaliy now it’s like this I had given all permissions to the mysql user, but for some reason this permission was denied. I installed phpmyadmin and then the installation page appeared, but when I click install, it stays on the same page.


In php.ini set display_errors to Off.
Instead you can log errors in the file log_errors = On

1 Like

In sudo nano /etc/php/7.2/apache2/php.ini
it is like this:

Default Value: On
; Development Value: On
; Production Value: Off

; display_startup_errors
; Default Value: Off
; Development Value: On
; Production Value: Off

Now I found it, but it was already the way you said it.

Can you also turn off displaying errors from OJS’s config.inc.php: https://github.com/pkp/ojs/blob/master/config.TEMPLATE.inc.php#L500

If it’s already off and errors are still displaying, most probably you have checked wrong php.ini. If not, the next step is to provide new install, in case of failing, look at the php logs (default path: /var/log/apache2/error.log). The should be a relevant log that starts with error or fatal error.

1 Like

Dołączyłem do /var/log/apache2/error.log i pojawiły się te pliki


Yes. By default error.log contains php errors if the apache configuration wasn’t changed.

1 Like