OJS 3.1.2 Administration page redirects to journal homepage [solved]

I recently upgraded to OJS 3.1.2 and now the Administration page is redirecting to my journal homepage. Everything else so far seems to be working fine.

I’m running CentOS 7, nginx 1.12.2 with fastcgi and php 7.2.16. I tried checking in OJS and the Administration link points to https://domain.tld/index.php/index/admin/index while now in OJS 3.1.2 it’s pointing to https://domain.tld/admin/index

When I visit the old admin url, I can see something resembling the admin page. Is anyone else having this problem or know of a fix?

Did you add restful_urls to config.inc.php for 3.1.2?

What are your baseurl settings in config.inc.php? Specifically, what is the value of base_url and of base_url[index] (if set)?

I would expect something like:

base_url = https://domain.tld
base_url[index] = https://domain.tld/index

No I didn’t have restful_urls enabled. But I did have base_url[index] = https://domain.tld.
Commenting out that line back out fixed the problem. Thanks!