OJS 3.1.2-1 PDF and HTML Galley Viewers Give Error "refused to connect"

I have tried this with OJS 3.1.2 and again with the update to 3.1.2-1, and the problem persists. I have a whole number published, and I included two galleys for each article, one for PDF and another for HTML. The HTML Article Galley plugin and the PDF.JS PDF Viewer plugin are both enabled, as shown in this screenshot:


However, when I go to an article and click on either the HTML or the PDF, I get the same error - a new tab opens with the article’s title across the top, but there is an error which says revistas.upeu.edu.pe refused to connect, as seen in the screenshots below:

The PDF option at least gives me a Download button, which does download the article PDF correctly.

The HTML option looks basically the same, it just doesn’t have the Download button. That said, if I change the address line from …/article/view/35/43 to …/article/download/35/43 manually, it does open the HTML file in my browser.

Any ideas on why both galley view plugins give me the same error about “refused to connect”? I looked for settings that I might need to configure in the plugin list, but there are no Settings options for these plugins within the Dashboard. Do I need to install anything additional to use these plugins? Or do some files on my server need certain permissions?

EDIT: Checking the logs, I found this message which I think is related, but I’m not sure.

[Wed Jul 17 18:01:55.813715 2019] [php7:warn] [pid 29116] [client] PHP Warning: Declaration of SubmissionKeywordEntryDAO::getByControlledVocabId($controlledVocabId, $rangeInfo = NULL) should be compatible with ControlledVocabEntryDAO::getByControlledVocabId($controlledVocabId, $rangeInfo = NULL, $filter = NULL) in /var/www/vhosts/revistas.upeu.edu.pe/httpdocs/ojs312/lib/pkp/classes/submission/SubmissionKeywordEntryDAO.inc.php on line 20

Hi @Michael_White,

Something blocks iframe content from being displayed. Apart from PHP logs, I’d check apache logs and browser’s console for details.