[OJS 3.1.2-1] 'ORCID collect' letters cannot be disabled

After we had upgraded to 3.1.2 our authors began receiving those ‘Orcid Collect Author Id’ letters. The first problem is there seems to be no way to disable them. The appropriate option in the ORCID plugin has always been disabled:

Also there is no option to disable the template itself (the checkbox is grayed out):

The second problem is the link to the ORCID site in the template seems to be broken:

Hi @Ph_We ,

I have the same problem, I think OJS 3.1.2.-1 sends this Orcid-Mails after an editor clicks “Send To Review”.
As a temporary solution, I commented this out in the function handleEditorAction() in OrcidProfilePlugin.inc.php. But it would be nice to have an option to switch it off.

Regards,
habib

1 Like

It doesn’t look like the option “sendMailToAuthorOnPublication” was used anywhere. I’ve opened an issue and PR for this. Can either of you test the change?

1 Like

Thanks, @ctgraham!
@habib, would you be so kind to test this? I do not have any possibility right now, sorry.

Sure, I can test this.

1 Like