[OJS 3.1.1] announcement in homepage not show

dear all, can you help my problem.

after i creat an announcement, with html code.

in editor announcement show image and link, but isnt show in mainpage


Have you activated this function: “Display x of the most recent announcements on the journal homepage”?

can you explain how ?


Go to settings → Website → Announcements and tick the checkbox:

Than you have to choose the number of announcements you want to display.


i already checked.

Have you put in an expiry date?
It’s the only explanation I have left.

i have put expiry til august 2018

Do you have made changes on the default theme? Or do you use a different theme?

different theme.
does it matter?

Maybe. If the theme has changed the frontpage and has not included announcements, they won’t be displayed, regardless of what is checked in the settings. If the theme has changed the frontpage, there should be the file indexJournal.tpl in templates/frontend/pages/. An this file should have a paragraph about announcements.


this my source indexjournal.tpl

Hm, looks alright to me. Unfortunately I don’t know what else to try. Maybe one of the developers has another idea.

Hi @hari_pramono,

The path to the image you’ve placed in the TinyMCE editor probably isn’t right when it’s translated onto the public facing website. In the editor, look at the HTML source to see whether it’s using a relative path; then check the source on the public facing website to see whether it’s appropriate. Adjust the URL in the editor as needed.

Alec Smecher
Public Knowledge Project Team