[OJS 3.1.1.0] Article statistics & Reference box

ojs3
Tags: #<Tag:0x007f769a232838>

#2

Hi @aabahishti,

Did you check if the stats plugin active?


#3

@Ph_We Yes, its active, I also deactivate to check and again activate but not showing for any article


#4

Hi!
Is there anyone else also have the same situation in OJS3.1.1 or its only with my installation?
Download statistics are not available on article page
No reference box during submission (step 3)


#5

Hi @aabahishti

Could you point me/provide a link to such an article without the download statistics, where you would expect some to be?
If enabled in Settings > Workflow > Submission > Submission Metadata, the reference input text field is now in a new tab for editors: when you open the article metadata modal, there should also be the new tab “References” there. Do you see it?

Best,
Bozana


#6

Hi! @bozana
Thanks for the reply. After upgrading in test installation download statistics is not showing at all even its enabled from the setting.

Yes, references are available for editor in different tab, but I meant that not available for author during submission. Is it expected?


#7

Did you enable it for submission forms in Settings > Workflow > Submission > Submission Metadata?


#8

Hi! @bozana
Yes, I enabled.
For download statistics, can you plz check any article at this journal (Later I will disable this journal as only for testing)


#9

Hi @bozana
Here is the screenshot of setting and submission page as author


#10

How are your usage statistics plugin settings (Settings > Website > Plugins > Generic Plugins > usage Statistics > Settings) for that journal? – It seems like the “Display submission statistics chart for reader” is not selected…

I’ll take a look regarding the reference input text field in my local installation… Your settings seem to be OK…

Thanks!


#11

Hi! @bozana
Yes, I selected from setting as in screenshot below (all settings are same as in earlier version 3.1.0 and I double checked all settings) -


#12

Regarding reference input text field: this is really strange, because I have no problems – as author I see the references field just after the supporting agencies and openAIRE filed:

SubmissionMetadata

Hmmm… Could you try to clear the OJS cache and open an article metadata submit page as author again?
Hmmm… I do not know what else could it be… Could you maybe also check if any error occurs (in PHP error log file and browser developer tools)? Hmmm… :open_mouth:


#13

Hi @bozana
Thanks for your reply. I will make a fresh upgrade to check if the problem still exist and report here probably by tomorrow.


Error usageStats plugin after upgrading from OJS 3.1.0-1 to 3.1.1
#14

Regarding the usage statistics graph: s. this GitHub Issue: https://github.com/pkp/pkp-lib/issues/3556. Please track that issue for the coming fix, that you would then need to apply :frowning:

EDIT: this change is needed: https://github.com/pkp/pkp-lib/pull/3559/files

THANKS!!!
Bozana


Article metrics problem in OJS 3.1.1
#15

Hi! @bozana
Appreciate your hard work and help. Above fix solved download statistic Issue.
Regarding reference box, I noticed that reference box appears properly when submit article with author role, However, if make a submission with journal manager/editor role reference box does not appear.

Kind Regards


#16

After upgrading OJS to 3.1 we are getting special characters at the end of references of previously added articles. Anyone knows the reason ?

Sample :

  1. Fung E, Nemeth E. Manipulation of the hepcidin pathway for therapeutic purposes. Haematologica 2013;98(11):1667–76.
  2. Hintze KJ, McClung JP. Hepcidin: A Critical Regulator of Iron Metabolism during Hypoxia. Adv Hematol [Internet] 2011. ID 510304, 7 pages. Doi:10.1155/2011/510304…
  3. Kwapis J, Slomka A, Zekanowska E. Hepcidin and its Role in Iron Homeostasis. EJFICC 2009;20(2):124–8.

#17

Hi @Haroon_Sattar
Its look like you changed following character_set_name in config.inc.php

connection_charset =
database_charset =
charset_normalization =

Just check that above setting is same in your previous installation and upgrade installation before initiating upgrade process.
There are many threads in the forum to convert and fix utf8/utf-8 character_set, kindly find it if this is the issue.


#18

Thank a lot ! @aabahishti It worked for me.
Can you please guide me how to add quick submit plugin in OJS 3.1 .

Regards


#19

Hi @Haroon_Sattar

I think you should as admin user go to the Settings > Website > Plugins > Plugin Gallery and install the plugin from there.

Best,
Bozana


#20

@bozana I was able to install the plugin manually. Thanks a lot for your time.

Can you tell me how to change the styling of Header of website. ?


#21

Hi @Haroon_Sattar

What exactly do you mean with “Header of website” ?

Best,
Bozana