[OJS 2.4.8] [Solved] Strange access problems

We are having strange problems:

  1. I can’t currently log out from my admin account (id 1) and journal manager account (id 3). Pressing ‘log out’ button brings to the /user page.
  2. I can’t ‘login as’ certain user. I can ‘login as’ other users, but after doing that I can’t ‘log out as’. (These too redirect to the /user page)
  3. The user that I couldn’t ‘login as’ can’t access submission they are supposed to review (Clicking link does nothing).
  4. Some times if I create private window and ‘log in’ 1. and 2. happens. Sometimes it works fine.
  5. If I open different browser (IE) I can log in and log out, but if I try to do that again it doesn’t let me to log out (Redirect to /user).
  6. At some point I was able to ‘login as’ the user that cannot access submission and access submission. At some point I could ‘login as’ the user, but couldn’t access submission. I cannot reproduce these two.

So what should I try to debug this?

Note: I have been cleaning admin users (id 1) sessions from database to be able to log out… Could this cause problems?

We have had problems with our server using it’s whole memory and mysql getting OOM killed (I have changed configurations and it shouldn’t happen again). This might have caused the problem?

Edit: NOTE: I have checked error_log and it has nothing there.

We just did this on the Journal Manager account (id 3):

  1. Long idle
  2. log out (doesn’t work)
    • One session
  3. close tab
    • Still has one session
  4. open site again
  5. needs login
  6. log in
    • Still has one session
  7. log out (works)
    • No session
  8. close tab
  9. open site again
  10. log in
    • One session
  11. log out (doesn’t work)
    • Still has one session
  12. close tab
  13. open site again
  14. needs login
    • Still has one session
  15. log in
  16. log out (doesn’t work)
    • Still has one session

So the problem has something to do with OJS not being able to remove session? That doesn’t still explain why log as doesn’t work or how to fix it.

Another experiment:

  1. Open IE and goto OJS
    • No sessions for 1
  2. Log in
    • One session for 1
    • No sessions for 1575
  3. log in as 1575
    • No sessions for 1
    • One session for 1575
  4. Log out as user 1575
    • One session for 1
    • No sessions for 1575
    • No sessions for 433
  5. Log in as user 433
    • No sessions for 1
    • One session for 433
  6. Log out as user 433 (failed)
    • No sessions for 1
    • One session for 433
  7. Log out
    • No session for 1
    • No session for 433

Because two different accounts reacted differently it’s not only session problem, right?

I did the same as in OP 5. again and this time recorded SQL commands ran to log file. It looks like it doesn’t issue any log out queries at all second time, so there is some check in OJS that fails before log out code is ran.


Some problems with sessions could be connected to session_check_ip = On setting in config.inc.php. Changing that to off solved a session related problems in our case. It could be that your problem is different (I am thinking especially those login as problems), but I guess that is worth trying.

Hmm… It could be that for the ‘login as’ problem, but wouldn’t that be quite infrequent? Currently I can semi-reliable trigger the ‘login as’ problem.

Anyways. Going to look at it again tomorrow.

Well… I found out what was the problem.

I had misconfigured apache and all html files were being cached by browsers. I have no clue why I didn’t notice that this was happening even though I was closely looking at the request and responses that were happening.

I’m also getting the same problems. All users not able to login in journal.

Hello @anuj_chauhan,

This is quite an older post. If you are experiencing issues similar to this, can you please create a new post and describe your issue there?

Thank you,

PKP Team