OAI-PMH validation error


We have tried to get our OJS journal http://aldizkaria.ankulegi.org/index.php/ankulegi) indexed at the OAI Register (https://www.openarchives.org/Register/ValidateSite), receiving the following error:

The response to the ListIdentifiers verb with metadataPrefix oai_dc contained no identifiers.

[Warning] Identifier 1, ‘oai:ojs.aldizkaria.ankulegi.org:article/1’, is for a deleted record, skipping

[Warning] Identifier 2, ‘oai:ojs.aldizkaria.ankulegi.org:article/2’, is for a deleted record, skipping

[1] The response to the ListIdentifiers verb with metadataPrefix oai_dc contained no identifiers. Without at least one identifier, we cannot proceed with the validation tests.

Our baseURL is http://aldizkaria.ankulegi.org/index.php/index/oai and the full error log is available here:

Unfortunately, we known really little about OAI-PHM and its implementation in OJS (if there is a step-by-step guide, we have not find it), so any help will be much appreciated. Sincerely,

We don’t known if this could be related to the problem, but our repository hosts six full/public available issues (with proper metadata, we hope) and thirteen empty/private issues (bare registers of the monographic sections’ titles). The reason for this is that we are digitalising backwards, starting from the most recent printed issues.

Hi @ankulegi,

As far as I know, that tool at openarchives.org is intended to test OAI repositories, not to actually perform any indexing. In order to perform the testing, it requires some content be present; it looks like your installation is reporting no published content. This probably means you have your journal marked as “disabled”. Check as Site Administrator in the “Hosted Journals” list; edit the journal; and check that it’s marked enabled.

Alec Smecher
Public Knowledge Project Team

It worked like a charm!! We didn’t realised that checking box.

Thank you so much, @asmecher!,

good evening, sir, my journal OAI also has error data, what is the solution, sir

there is a message like this
This record has been deleted.

Hello @Ganda_Public,

Could you please make a new topic with the information of your OJS version and the OAI errors you’re receiving? This is a very old post, so I think your issue will be easier to find in a new thread. Thank you!