OAI-PMH validation error (OJS3)

Hello,
I need your help. When I submit to http://validator.oaipmh.com/ , I have some errors concerning listrecords oai_openaire_jats:

  1. Line 26, Column 0, Element ‘{http://www.openarchives.org/OAI/2.0/}article’: This element is not expected. Expected is ( ##other{http://www.openarchives.org/OAI/2.0/}* ).
  2. Line 161, Column 0, Element ‘{http://www.openarchives.org/OAI/2.0/}article’: This element is not expected. Expected is ( ##other{http://www.openarchives.org/OAI/2.0/}* ).

https://journals.scinnovations.uz/index.php/idmfs/oai?verb=Identify

OJS 3.3.0.10

Screenshot_15

@jonasraoni: would this be related to the bug that you filed recently here: Improve the configuration for the OAI endpoint · Issue #8414 · pkp/pkp-lib · GitHub

-Roger

Hi @rcgillis!

This is something else, the problem is on an external plugin, which is not part of our codebase, perhaps the user could leave a comment here: Invalid XML file created · Issue #6 · ojsde/openAIRE · GitHub

Best,
Jonas

1 Like