No navigation bar

I have done a test upgrade for our journals from to 3.1.0

It went fine except after upgrading there isn’t link to login page in the reader part:
It seems that the whole navigation bar is missing.

I tried looking at the templates and code, but couldn’t figure out what was going on.

The upgrade was done as instructed in the UPGRADE file. (I extracted to different directory, moved old ojs, renamed the directory, moved config and public directory, went through the config, ran upgrade script and made it installed again)

I can give access to the test site if needed. Access to it is currently filtered by IP.

Apparently by default there aren’t any navigation menus? I tried to add one for logging in, but it didn’t do anything.

Is this code right? Should you be able to enable blocks from disabled plugins? Also wouldn’t that break completely if the plugin provides both sidebar and non-sidebar blocks?

Also if you disable plugin that has enabled block this breaks.
I have had that happen with sidebar block manager and after I enabled the plugin again it didn’t show the block in it’s list. So I couldn’t turn the block of again.