No input file specified. -- ojs-2.4.8

Dear all,

I am trying to install ojs-2.4.8. After all the steps and suggestions, I get “No input file specified.”. The hosting is provided by godaddy. Any suggestions?

Thanks a lot!


What step in the install gives you the “no input file specified” message? Is this the response of running a shell command at the command line, or something you see in your web browser?

Thanks a lot! I fixed already…now I am having problems with “The directory specified for uploaded files does not exist or is not writable.” Any idea how to give full permission (already tried godaddys panel - privacy) or there to get the full path? Thanks!

The directory is specified in’s files_dir. The directory you specify here needs to be writable by the web server, but should not be directly exposed by the web server.

The method of making that happen will vary by host, so in your case you will want to check with GoDaddy support. See this for a possible starting place:

Dear pulgarinp, how did you fix your problem? I am experiencing the same issue. thank you

Hi @erik,

That user described two different problems; which are you encountering?

Alec Smecher
Public Knowledge Project Team

Hi Alec, I was experiencing ‘no input file specified’ – I do not see it now, I think that I have fixed it by following this solution

The next problem I am experiencing is with pointing the setup to the Directory for uploads. I have set up a folder with this pathway

the folder is writable with permission 0755 on linux

I will get this error message:

Errors occurred during installation:
The directory specified for uploaded files does not exist or is not writable.

I have tried

I have read this post but without any luck

thank you, Erik

There are two directories for uploaded files in your files_dir (for protected journal files like articles and issues galleys), and public_files_dir (for public web files, like CSS, images, and javascript).

The message “The directory specified for uploaded files does not exist or is not writable.” applies to the files_dir (private files).

The files_dir should live outside of your webroot. That is, it should not be directly accessible via the web.

Both configuration directives should be an absolute path or a relative path from your OJS installation, from the filesystem perspective, not from the public web perspective.

Say, for example, your OJS is installed on the server in:
and you wanted to put your public files in
and your private files in:

Your configuration directives could be any combination of:

files_dir = /user/home/username/dma_files
files_dir = ../../../dma_files
public_files_dir = /user/home/username/public_html/
public_files_dir = public

The web path to your public files would be:
There would be no direct web path to your private files.

Dear Graham, thank you for your help!

At the end my colleague has helped me with this by following your instructions. She suggested to use a relative path …/files/public which worked.

I was able to install OJS on the shared GoDaddy server.

However, I would like the ojs to work under this pathway ‘’ (ojs is there) but when I long in then it links with the installed WordPress site which is installed in that server folder ‘
The OJS installation is in this folder ‘

Note that the ojs installation was linked to a (newly created) separate database from the WordPress database linked to the ‘’ site

I have created a new ‘journal’ on ‘’ but it is not possible to login to it from that link – it takes me to a page on ‘’ which cannot be found

whereas I can login using ‘

Would you know if it would be possible to modify ojs so that it runs within the ‘’ path?

thank you, Erik

More important that the exposed urls will be how your underlying filesystem is structured and how that is mapped to the exposed urls.

For example, you may have a common public_html folder, which contains various sites underneath it:


How these directories map to your DNS names will determine the correct configuration.

Can the same colleague who suggested the relative path help with this as well?

Alternately, please describe your filesystem and configuration in as much detail as you can.