Newly registered users do not have author role

Hi everybody,
We have updated our website from ojs2.4.8 to ojs3.1.1-2 and everything is fine! But, our new users only have ‘reader’ role after registration and they should manually add the ‘author’ role from profile page (which most of them do not know and contact us for this).
Is there a way to automatically assign the author role to users when they register?

They can just go and do a submission and choose any available author role in the first stage of the submission process. This means that accessing the submission form does not require the Author role anymore. This is a recent change in OJS.

the link to submit a new submission is not available anywhere! how could they submit?!
there is a link to submit a new article exactly after registering in the website. but the submission tab does not show in the dashboard unless they have the ‘Author’ role.
Is there a way to automatically give them the ‘author’ role. this is really troubling for less experienced users.

There should be a submission button available at least under About > Submissions on the public page. Also when you enter the dashboard, there should be a “New submission” link on the left. You can also enable the “Make a Submission” block to make it more apparent.



Hi again,
there is no link in the left column! :thinking:
maybe I should enable something, but I went through the setting and found nothing relevant.


hmm, are you sure you have OJS and did you try deleting the OJS file cache?

I can actually see a problem in the code showing that button: pkp-lib/header.tpl at ojs-stable-3_1_1 · pkp/pkp-lib · GitHub

It checks whether the user only has one role and if that role is Reader. If that is true, it will show the “New submission” button. BUT if you are in a multijournal installation there will be users that have NO roles in some journal, not even the Reader role, so it will not show the button.

@NateWr how about adding a check there that shows the button also for users without any roles?

my version is : (June 29, 2018 - 07:00 AM)
I manually edited the security fix.
This user has the reader role but still there is no link.


I figured it out.
it was a problem with the selected theme.
tnx for the reply

1 Like

Hey Bro,

How you have done this… I have the same issue as well, I want to bring Author as a role on the registration page.

Sher Azam