Network Status Messages

After joining the PKP PLN and accepting the settings and terms of use I am getting these two Network Status messages - “The PKP PLN does not know about this journal yet and the other message” and for the other journal - “The PKP PLN can accept deposits from this journal.” Thoughts? Suggestions?

There is an expected delay before the PLN picks up new journals and slurps their content. If this persists, you can provide your URL and journal title to @mjoyce for a detailed check of the status.

Hi @VMcLean. Can you provide the URL, title, or UUID for the journals causing you concern?

Some time ago I submitted all journals from the OJS instance available at ISS PAS Journals to PKP PLN, but the LOCKSS Status is either Unknown (in case of one journal) or the general note “The PKP PLN does not know about this journal yet” in case of all other journals.

Would be grateful for further details on the above journals status.

I have acron plugin enabled for all journals and Archive_Tar module installed:
Package Version State
Archive_Tar 1.3.12 stable

There are number of files in the scheduledTaskLogs called PKPPLNDepositorTask…. . The file with yesterday’s date includes:

[2016-11-13 22:45:24] [Notice] Task process started.
[2016-11-13 22:45:24] [Notice] Depositor processing for ABS.
[2016-11-13 22:45:24] [Notice] Getting service document.
[2016-11-13 22:45:25] [Notice] Processing deposit status updates.
[2016-11-13 22:45:25] [Notice] Processing updated content.
[2016-11-13 22:45:25] [Notice] Processing new content.
[2016-11-13 22:45:25] [Notice] Packaging content for deposit.

That’s all there.

Hi @piotreba

Thank you for finding the scheduled task logs. They’re very useful. It looks like something is going wrong when packaging content. In my journals, the logs look more like this:

[2016-06-15 09:27:08] [Notice] Process new deposits: 16
[2016-06-15 09:27:08] [Notice] Process new deposits for object type Issue
[2016-06-15 09:27:08] [Notice] Packaging content for deposit.
[2016-06-15 09:27:08] [Notice] Process need packaging: 16
[2016-06-15 09:27:08] [Notice] Process need package: 40C36144-4312-4D0E-A1E8-6D362E1377C4
[2016-06-15 09:27:09] [Notice] Process need package: 1785E9F8-907F-4C79-99BE-38FBB59F9235
[2016-06-15 09:27:18] [Notice] Sending deposits to the PLN.
[2016-06-15 09:27:18] [Notice] Process need transferring: 16
[2016-06-15 09:27:18] [Notice] Process need transfer: 40C36144-4312-4D0E-A1E8-6D362E1377C4
[2016-06-15 09:27:19] [Notice] Process need transfer: 1785E9F8-907F-4C79-99BE-38FBB59F9235
[2016-06-15 09:27:20] [Notice] Task process stopped.

It looks to me like the plugin is either having trouble packaging content for deposit or isn’t figuring out which deposits need packaging.

Can you reset one or two deposits? That should cause them to be repackaged when the plugin runs next.

Ok, I clicked on reset buttons next to all deposits of the one journal. For all other journals I don’t have access to these buttons as none deposits are visible on the “Status” page of the plugin. Unless you meant other way to reset the plugin?

I checked the status of the journals today and nothing has changed (one journal with six deposits of Unknown status, rest of the journals with a note note “The PKP PLN does not know about this journal yet”). The PKPPLNDepositorTask file with yesterday’s date includes:

[2016-11-16 22:46:06] [Notice] Task process started.
[2016-11-16 22:46:06] [Notice] Depositor processing for ABS.
[2016-11-16 22:46:06] [Notice] Getting service document.
[2016-11-16 22:46:08] [Notice] Processing deposit status updates.
[2016-11-16 22:46:08] [Notice] Processing updated content.
[2016-11-16 22:46:08] [Notice] Processing new content.
[2016-11-16 22:46:08] [Notice] Packaging content for deposit.

Hello @piotreba

I can’t find any indication in the log files that your journal has tried to create a deposit. From what I’ve seen here on the forum, it looks like the journal isn’t able to create deposit packages. Server internals are a little outside my area, unfortunately. Here are some things to try, with my apologies for ideas you’ve already tried.

  • File permissions - OJS must be able to write to the journal files directory and create directories in it.
  • Libraries - OJS must have access to Archive_Tar to create a deposit. It’s easiest to install via PEAR
  • Libraries - And Archive_Tar must be available in the PHP include_path configuration

I can’t really think of anything else. Maybe @asmecher or @ctgraham can help out.

Hi @piotreba & @mjoyce,

@piotreba, are you using a proxied Internet connection from your server?

Alec Smecher
Public Knowledge Project Team

No, as far as I’m concerned it is not.

Does your log really end with:


That is, there isn’t a final: [Notice] Task process stopped.?

That would seem to imply a fatal error somewhere in:

My first guess aligns with @mjoyce’s: does the “pln” directory exist under your journal id under files_dir?

The file from yesterday includes only this:
url to OJS
[2016-11-23 22:49:44] [Notice] Task process started.
[2016-11-23 22:49:44] [Notice] Depositor processing for Acta Baltico-Slavica.
[2016-11-23 22:49:44] [Notice] Getting service document.
[2016-11-23 22:49:45] [Notice] Processing deposit status updates.
[2016-11-23 22:49:45] [Notice] Processing updated content.
[2016-11-23 22:49:45] [Notice] Processing new content.
[2016-11-23 22:49:45] [Notice] Packaging content for deposit.

There’s no “[Notice] Task process stopped.”

Before enabling the plugin, the file looked like below:
url to OJS
[2016-10-14 22:21:48] [Notice] Task process started.
[2016-10-14 22:21:48] [Notice] Task process stopped.

And yes, I have “pln” directory under this journal’s ID. It includes some other folders and files. The files are empty, with the exception of bagit.txt which contains some default content I suppose (BagIt-Version: 0.96
Tag-File-Character-Encoding: UTF-8), there is also “data” folder, without any content. But only a single journal contains the pln folder, other journals do not (as I wrote in earlier posts I only have “signs” of the plugin activity for one journal within the same OJS).

I just noticed that pln directory is not under the individual journal folders. Should the pln folder be at this path:
If so, is enabling the plugin supposed to be enough to get that directory inserted? Or does that need to be a manual step?

That’s interesting!

If you look in the file, there’s an entry for files_dir. On my laptop, that entry points to /var/www/ojs/files, and the pln folder gets created at /var/www/ojs/files/journals/{journal_id}/pln.

Enabling the plugin should be enough to get the directory created, but it shouldn’t be in the uploads path.

Hi all,

Note that there’s a potential security risk in having the files_dir live inside your web root. Ensure that you either move the files_dir somewhere outside your web root, or protect its contents from access using an .htaccess document or similar mechanism.

Alec Smecher
Public Knowledge Project Team

Did you ever get this to work. I’m having the same issue. PKP logs end with Packaging content for deposit. On a related note, how does the runscheduledtasks tool know to run the PLN plugin. I looked in the scheduled tasks xml file and do not see any reference to PLN. Thanks!


Well… I am not sure. Some of the journals (or only some issues within a journal) display the following status:

Checked: (empty)
Local Status: Unknown
Processing Status: Unknown
LOCKSS Status: Agreement
Complete: Yes

While another ones:

Checked: 2017-06-30 17:33:14
Local Status: Transferred
Processing Status: Unknown
LOCKSS Status: Unknown
Complete: No

So I actually don’t understand these infos. Do you think I should reset processing of every issue?