Need Urgent help: clicking on article gives HTTP ERROR 500

Hi all

I am using OJS and all is OK. I have 2 journals there. One is working great and all articles are displaying correctly. However, I added another journal and again all is Ok except when use tries to actually click on an article. I am testing this and removed and re-created the journal thinking maybe something was wrong in my initial set up.

I can see the TOC, article and even get the PDF. The issue is when I click on the article to see metadata for example, then I get the error. So basically the error is on “…/article/view/47”

This is driving me crazy as I cannot find an logical explanation… One journal works great and the new one I am testing on the same platform is going all loopy on me:slight_smile:

Appreciate any help!

Hi @Ted,

What does php error log file in your server read?


I cannot access the Log files as I am not the server admin, so only OJS Web Interface… The person dealing with that side of the equation is on leave :frowning:

Just tried to add an article on the other journal hosted on the same platform and works great!

Did the exact same steps on this new tile and boom the error is there.

Dont get why it is working one one title and not on the other as they are both on same environement…

Tearing my hair down…+

Hi! @Ted
It might be due to some mandatory data missing in the metadata of that article. You may check by login through journal editor role and check all metadata of that individual article including author(s) first name, last name.

Let me check this… Curious to see if this is the issue:)

No, that’s not the issue. Tried everything on the meta data so that minimal info is required. Still no go. I can see the article on table of content, and I can even click on PDF and get the document. I simply cannot see what I am doing wrong…
When i go to Schedule for publications, I do see a notification: Assign a user to create galleys using the Assign link in the Participants list.
Did the same step on another OJS installation and all worked as expected following the same steps.
Dont knwo what to do next:(

No longer an issue but more problems with my hosting meant I had to destroy the instance, restore from back up and reset all credentials. After that, moved all papers to a completely new installation on different environement (more secure).
Reason: OJS was hacked by Defacement virus!!!
No idea how this came about but caused some embarrassment :frowning:
Anyway, lesson learnt: get solid hosting and reset credentials periodically!!!

1 Like

Hi @Ted,

Was your files_dir (in within your web root? If so, that’s an unsafe deployment – see docs/README for details. (This is also noted on the installation form and elsewhere.)

Alec Smecher
Public Knowledge Project Team

1 Like

Hi Alec
Not sure about the file structure to be honest as this was done by a freelancer so I am guessing this was not looked at in details:frowning:frowning:
I moved the entire thing to a new host and all files are correctly put and secure (install made by OJS specialist!!!)
Should take security more seriously these days…
Appreciate all your support from the communitiy!


Instead of open up a new analogous thread, I thought I would resurrect this one as it describes the issues we’re facing at present. We’re on OJS and we’re experiencing the following two problems:

  1. The download URLS on the website that allows users to view the published submission galleys result in a HTTP 500 error. (see Yet somehow when navigating through the journal manager dashboard to the article archives, the pdf of the galley is fully accessible when clicking on the submissions galley title (i.e. at the following URL Clicking on that title prompts the browser to display the file. When hovering over the URL imbedded in the submission title it displays the following ($$$call$$$/api/file/file-api/download-file?fileId=636&revision=1&submissionId=159&stageId=5) - I’m not sure if this offers any clues…

The author submission wizard appears to stall and doesn’t allow the author to confirm the upload of their submission. As an example, generating a new submission as an author:

  • I click on the new submission link which takes me here:
  • I fill in the first page of the wizard with all the correct detail and click “Save and Continue” this navigates to the “Submit an Article” screen (
  • I fill in the dialogue box and choose a file for ‘upload’, it appears to upload (progress bar continues to 100% and the file with its title displays in the dialogue box.
  • I hit the “Continue” button and the subsequent screen displays.
  • I choose not to edit the file name but click “Continue”. At this point the wizard stalls and does not continue on to Step 3 “Confirm”.
  • If I click “Cancel” the wizard exits and my uploaded article appears to display (counter intuitively…that must surely be a bug). I however can’t navigate through the remainder of the submission process, i.e. “3. Enter metadata”, “4. Confirmation” etc.). This leaves our authors in the challenging position of not being able to upload their content.

Are the two issues perhaps related? Would checking the error logs be the first step?

Thanks in advance for your help! :slightly_smiling_face:

I have the problem in title of the paper “A Review: Cloud Computing Technologies and It�s Technical Improvements”. Due to ? which shows space. We cannot edit the metadata of the paper. Where we can find the title of paper in OJS Even the submission dashboard this article gives error "unxpected error due to above mentioned problem. I have tried to find the title of the paper in the database but not successful. Where the title of the papers stored in OJS 3 version.