My first experience and problems with Local installation of OJS 3

Hello All,
I have upgraded my journal website from OJS 2.4.8 to OJS 3.

Everything went well and I have succefully upgraded.
There is my site-name on Top left and Three menu items just below it. They all work fine.
There is a right side-bar with Information block containing three links. They all work fine.
On the very top-right, there is my username. When I hover over it, there comes 4 drop-down like menu items.

My problem starts from this point on:
Whichever the link I press among 4 drop-down like menu when i hover over my username on top-right,
I go to a page with a menu on left bar and contains Tasks, Submission, Issues etcs.
A circular cursor keeps circling in the task menu forever and
most of the links in the left bar or in the main page throws error with a blank white page containing a line of code as below:


I am using latest XAMMP with PHP/5.6.23 and i believe it keeps up with the recommended requirement.

To be sure that my XAMP is working well, I wiped the htdocs directory and installed my backed-up 2.4.8 and everything seems to work fine.

Here are my snapshots of what i tried to describe above.

I would love to hear from anybody who has any idea of whats going on?



My localhost was throwing problems as i have mentioned in my above post, despite all I could do.
However, I uploaded my site as a subdomain to my main site for trial, and everything seem to work fine.

So, I am exploring OJS 3.0, Hurray.


Hi @anupent,

Glad to hear it! If you’re able to shed any light on the problems you encountered on your local machine, feel free to follow up here.

Alec Smecher
Public Knowledge Project Team

1 Like


I just upgraded a test installation with 25+ journals with a few years of content in them. The frontend is working but loading the admin side gives the exact problem desrcibed in the first post.

The javascripts keep on loading and nothing happens. Firebug gives this error: Error: The handler "$.pkp.controllers.SiteHandler" has already been bound to the selected element! Handler.js (line 38, col 10)

Clicking for example My queue link gives this (not seeing the tabs under submission, only three links):
{"status":true,"content":"\n<a href=\"#\" class=\"requestHelpPanel pkp_help_link pkp_help_tab\" data-topic=\"\">\n\t\t\tHelp\n\t<\/a>\n\n<script type=\"text\/javascript\">\n\t$(function() {\n\t\t\/\/ Attach the form handler.\n\t\t$('#contextSubmissionForm').pkpHandler('$.pkp.controllers.dashboard.form.DashboardTaskFormHandler',\n\t\t\t{\n\t\t\t\tsingleContextSubmissionUrl: \"http:\\\/\\\/\\\/index.php\\\/journal_name\\\/submission\\\/wizard\",\n\t\t\t\ttrackFormChanges: false\n\t\t\t}\n\t\t);\n\t});\n<\/script>\n<div class=\"pkp_context_sidebar\">\n\t\t<div class=\"pkp_tab_actions\">\n\t\t<form id=\"contextSubmissionForm\">\n\t\t\t<ul>\n\t\t\t\t<li>\n\t\t\t\t\t<button class=\"pkp_button \" type=\"button\" id=\"singleContext\" >New Submission<\/button>\n\t\t\t\t<\/li>\n\t\t\t<\/ul>\n\t\t<\/form>\n\t<\/div>\n\t<\/div>\n\n<div class=\"pkp_content_panel\">\n\t<!-- Unassigned submissions grid: If the user is a manager or a series editor, then display these submissions which have not been assigned to anyone -->\n\t\t\t\n\t\t\n<script>\n\t\/\/ Initialise JS handler.\n\t$(function() {\n\t\t$('#unassignedSubmissionsListGridContainer').pkpHandler(\n\t\t\t'$.pkp.controllers.UrlInDivHandler',\n\t\t\t{\n\t\t\t\tsourceUrl: \"http:\\\/\\\/\\\/index.php\\\/journal_name\\\/$$$call$$$\\\/grid\\\/submissions\\\/unassigned-submissions\\\/unassigned-submissions-list-grid\\\/fetch-grid\"\n\t\t\t}\n\t\t);\n\t});\n<\/script>\n\n<div id=\"unassignedSubmissionsListGridContainer\">\n<div class=\"pkp_loading\">\n\t<span class=\"pkp_spinner\"><\/span>\n\t<span class=\"message\">Loading<\/span>\n<\/div><\/div>\n\t\n\t<!-- Assigned submissions grid: Show all submissions the user is assigned to (besides their own) -->\n\t\n\t\n<script>\n\t\/\/ Initialise JS handler.\n\t$(function() {\n\t\t$('#assignedSubmissionsListGridContainer').pkpHandler(\n\t\t\t'$.pkp.controllers.UrlInDivHandler',\n\t\t\t{\n\t\t\t\tsourceUrl: \"http:\\\/\\\/\\\/index.php\\\/journal_name\\\/$$$call$$$\\\/grid\\\/submissions\\\/assigned-submissions\\\/assigned-submissions-list-grid\\\/fetch-grid\"\n\t\t\t}\n\t\t);\n\t});\n<\/script>\n\n<div id=\"assignedSubmissionsListGridContainer\">\n<div class=\"pkp_loading\">\n\t<span class=\"pkp_spinner\"><\/span>\n\t<span class=\"message\">Loading<\/span>\n<\/div><\/div>\n\n\t<!-- Author and editor submissions grid -->\n\t\t\t\n\t\t\n<script>\n\t\/\/ Initialise JS handler.\n\t$(function() {\n\t\t$('#mySubmissionsListGridContainer').pkpHandler(\n\t\t\t'$.pkp.controllers.UrlInDivHandler',\n\t\t\t{\n\t\t\t\tsourceUrl: \"http:\\\/\\\/\\\/index.php\\\/journal_name\\\/$$$call$$$\\\/grid\\\/submissions\\\/my-submissions\\\/my-submissions-list-grid\\\/fetch-grid\"\n\t\t\t}\n\t\t);\n\t});\n<\/script>\n\n<div id=\"mySubmissionsListGridContainer\">\n<div class=\"pkp_loading\">\n\t<span class=\"pkp_spinner\"><\/span>\n\t<span class=\"message\">Loading<\/span>\n<\/div><\/div>\n\t<\/div>","elementId":"0"}

Any suggestion where to start debugging?

1 Like

I had a similar problem and it was domain - redirection related. With all worked perfectly, buy with I saw continious loading icon. So I simple configured proper redirection in my apache. This can be done also by modifying htaccess file

1 Like

Thank you, I will try this. However, I already did a test where I installed a fresh OJS 3.0 to a subfolder of the same server and there everything worked fine.

I had tons of other problems as well so I am currently doing a new test upgrade. I will let you know in this thread whether the new upgrade solves this.

1 Like

Hi @ajnyga,

If you’re getting directed to a page containing raw JSON, chances are that you’ve already hit an error that was the cause of the problem and it’s confused the system to the point where it’s not handling Javascript events as it should. I’d suggest checking your Javascript console and potentially your PHP error log to see if there’s anything useful there. If you like, PM me some temporary credentials to your installation and I can take a quick look.

Alec Smecher
Public Knowledge Project Team


Yes, the second error is definitely due to the fact that the tabs are not loading at all. For some reason all javascript gets stuck.

Thank you for your offer. I will do another upgrade test today and see what happens. Yesterday the second attempt ended in an duplicate key error that I did not get in the first time. I will try to solve that first, maybe the easiest is to disable the index for the time of the upgrade and add it later.

1 Like

Follow-up to this topic.

My new upgrade test went better and I now have a functioning OJS3 installation with 45 journals with old content.

I had some problems with the journal_settings table already in OJS2 when I turned on warnings, so I fixed those first (WARNING: Cannot use a scalar value as an array In file: classes/journal/ At line: 83 and WARNING: Illegal string offset ‘fi_FI’\n In file: classes/journal/\n At line: 83 )

I the made a fake fi_FI and sv_FI locales to OJS3 that I used in the upgrade because these locales are used in our database. These are both locales that are not supported in OJS but we have our own translations. We are doing a Finnish translation for OJS3 and will do a pull request with it.

I earlier had a lot of errors related to locales during the upgrade and these two solved those all.

Furthermore, I updated my 2.4.5 to before going to 3.0 and removed all unnecessary test journals etc.

With these fixes (and a lot of minor ones, for example removing a duplicate key) the upgrade went trough. I had a lot of errors regarding supplementary files, but I will open a thread about that later when I have had time to explore it.

After the database upgrade to OJS3 most of the admin panel loaded but I still had problems with loading the submissions view. The reason for this was that I had errors and warnings turned on in config, so be sure to check that first if something is not loading.

Overall, looks promising.

1 Like

A new follow-up to this issue.

After doing yet another test upgrade to solve some other problems, I ran to this issue again.

I tried emptying OJS cache and also tested the solution Vitaliy described, but nothing worked.

However, this morning I opened the site with another computer and everything worked. So, it turned out that it was the browser cache that was causing the problem. I do not know what was in the cache, but it was maybe coming from the old OJS2 installation in the same address and was somehow messing things up in OJ3. After deleting my browser cache all javascript is loading.


Hi @ajnyga,

OK – thanks for following up!

Alec Smecher
Public Knowledge Project Team

I ran into exactly the same problem. Clearing cached images and files did the trick!

I upgraded an installation from version to 3.0.2 and occasionally this error is displayed. I set a scheduled task on the CRON to clean every 30 minutes but it is not working.

Other errors I managed to handle and returned the community via GitHub. But this one I still can not deal with.

DETAIL: My server running APACHE with FastCGI.

Any solution?

Are you sure that this message goes from OJS?


What error exactly do you get and when exactly and where do you see it and… Please provide as much information as possible…



I’ve got very similar prolems with the test upgrade to OJS 3. as Anupent.
I created a backup folder of PKP and Files and renamed them. The database was also backuped and the name of new database was used in the backup folders. These were upgraded to OJS 3. The upgrade was succeful, however, the loading icon showed that loading continued (see image below).

The tabs had difficulty loading and some (e.g., Tasks) did not load at all, others when clicked on produced an error message - the same as Anupent’s.

I checked the error log and it was empty.

I tried opening a .PDF article but it gives an error message (see below).

Could the problem be due to file permissions? Perhaps file location? Any suggestions?

Thanks a lot in advance. Regards.

Hi @planinc,

Rather than reopening an old thread, can you post this as a new topic?

Alec Smecher
Public Knowledge Project Team